Results 1 to 35 of 35

Thread: Testing Radiator Pressure

  1. #1
    E500E Guru emerydc8's Avatar
    Join Date
    May 2011
    Location
    Tucson, AZ
    Age
    51
    Posts
    1,133

    Testing Radiator Pressure

    I bought a radiator pressure test kit from HF and decided to check out one of my E420s. This car has always been remarkably cool during the hot Tucson summers, so I thought I might use this as a baseline. There are no visible coolant leaks and I haven't had to add any coolant since I last replaced the hoses about two years ago. To that end, I pumped it up to 15psi and hacked the clock. Here's the result of the bleed-down (if it's even supposed to bleed-down):

    10 psi in 11 min
    7.5 psi in 20 min
    5 psi in 30 min

    Is this normal?
    Jon D.
    1994 E420
    1995 E420

  2. The Following User Says Thank You to emerydc8 For This Useful Post:

    TerryA (4 Weeks Ago)

  3. #2
    .036 Hoonigan™
    E500E Boffin
    gsxr's Avatar
    Join Date
    Dec 2008
    Location
    Boise, ID, USA
    Posts
    17,768

    Re: Testing Radiator Pressure

    Jon, I'd say no, that isn't normal. It should hold pressure longer. Was there any trace of liquid coming out somewhere? Also, are you sure the tester itself is not the source of the leakdown?


  4. The Following User Says Thank You to gsxr For This Useful Post:

    TerryA (4 Weeks Ago)

  5. #3
    E500E Guru emerydc8's Avatar
    Join Date
    May 2011
    Location
    Tucson, AZ
    Age
    51
    Posts
    1,133

    Re: Testing Radiator Pressure

    Absolutely no visible leaks whatsoever. I'll check the tester.

    [EDIT]: The tester piston doesn't bleed down at all. The only other place it could be leaking is where the adaptor goes into the radiator neck. I'm trying to find something of similar size to test it on. This Maddox kit has more than dozen different adaptors and none of them will fit my 92 Z28, so I can only use it on my Mercedes anyway. For $90 I'm thinking of returning it tomorrow.

    I will try it on my other E420 later tonight, which is really why I bought the kit to begin with. Since installing a Graf water pump on that car a few months ago, it has been running about ten degrees hotter. All the fans are working properly and the viscous fan passes the roar test.
    Last edited by emerydc8; 04-10-2017 at 06:14 PM.
    Jon D.
    1994 E420
    1995 E420

  6. The Following 2 Users Say Thank You to emerydc8 For This Useful Post:

    gsxr (04-10-2017), TerryA (4 Weeks Ago)

  7. #4
    E500E Guru
    Join Date
    Feb 2012
    Posts
    630

    Re: Testing Radiator Pressure

    I have the HF kit, the adapters can bleed a little

  8. The Following User Says Thank You to alabbasi For This Useful Post:

    TerryA (4 Weeks Ago)

  9. #5
    E500E Guru emerydc8's Avatar
    Join Date
    May 2011
    Location
    Tucson, AZ
    Age
    51
    Posts
    1,133

    Re: Testing Radiator Pressure

    Thanks, alabbasi. It was the adaptor after all. I used some dielectric tuneup grease to help seal it and it is now holding.

    In fact, both E420s are holding 15 psi, which leaves me puzzled as to why the car with the new Graf water pump has been running hotter.

    I can't find any numbers on the pump that came off the car (this was not the original), so I don't know what it is. I wonder if the impellers vary by the brand of pump. It seems that the cooling efficiency was lost when I installed the Graf PA578 pump. I have the old-style pump (119 200 15 01). In stop-and-go traffic, the high-speed fans kick in and stop it from getting over 105c but they don't drop the temperature -- it seems to stabilize right at 105 -- and the fans could run indefinitely like that with no decrease in temperature. It's not a big deal at 85f outside but when it gets to 115 it's going to overheat for sure. That's strange because this car ran so cool with the other pump that I'm tempted to rebuild it and slap it back on.
    Jon D.
    1994 E420
    1995 E420

  10. The Following User Says Thank You to emerydc8 For This Useful Post:

    TerryA (4 Weeks Ago)

  11. #6
    .036 Hoonigan™
    E500E Boffin
    gsxr's Avatar
    Join Date
    Dec 2008
    Location
    Boise, ID, USA
    Posts
    17,768

    Re: Testing Radiator Pressure

    Jon, were there any other changes at the same time you installed the water pump? New t-stat for example? Radiator? Etc...

    Dave M.
    1997 E420 (Bugeyes)
    1994 E420 (Blondie)
    1994 E500 (Q-ship)
    1992 500E (Mach 5)
    1987 300D (Sportline Stage 2)
    Click here for my website
    Click here for my YouTube channel

  12. The Following User Says Thank You to gsxr For This Useful Post:

    TerryA (4 Weeks Ago)

  13. #7
    E500E Guru emerydc8's Avatar
    Join Date
    May 2011
    Location
    Tucson, AZ
    Age
    51
    Posts
    1,133

    Re: Testing Radiator Pressure

    Nothing. I even kept the coolant ratio the same -- about 30%.
    Jon D.
    1994 E420
    1995 E420

  14. The Following User Says Thank You to emerydc8 For This Useful Post:

    TerryA (4 Weeks Ago)

  15. #8
    E500E Guru emerydc8's Avatar
    Join Date
    May 2011
    Location
    Tucson, AZ
    Age
    51
    Posts
    1,133

    Re: Testing Radiator Pressure

    [UPDATE]:

    I flushed the system thoroughly, changed the thermostat and refilled with 30% Zerex G-05. The old thermostat seemed fine though. Still no change.

    There doesn't seem to be any obstruction in the cooling system. The water from a garden hose flows freely throughout the radiator and engine. But still, after about 25 minutes of driving at 76 degrees outside and the a/c blower on high (full cold), the temp creeps up and sets off the high speed fans when I come to a stop and let it idle for about five minutes. Subsequently, the fans do almost nothing to drop the coolant temp. I sat there for five minutes and the temp stayed steady. If I switch from full a/c to full heat, it drops it right back below 100C in less than a minute. My experience with high-speed fans is that you can watch the gauge drop after they kick in. It's not happening here.

    I have no idea why this is running so hot. The only thing I can suspect at this point is the new Graf water pump is not moving the coolant like the old one.

    I know the newer style pumps with the different thermostat housing are thought to flow more coolant. Has anyone had an experience like this after installing a new after-market water pump? Napperville sells the reman OEM for about $200 so that's my next step. The radiator is only about a year old.

    Out of curiosity, should it be this easy to slow the low-speed fans to a stop?

    https://youtu.be/AXwzFzL3rds

    Last edited by emerydc8; 04-15-2017 at 12:53 PM. Reason: Added video
    Jon D.
    1994 E420
    1995 E420

  16. The Following 2 Users Say Thank You to emerydc8 For This Useful Post:

    500AMM (04-16-2017), TerryA (4 Weeks Ago)

  17. #9
    E500E Guru emerydc8's Avatar
    Join Date
    May 2011
    Location
    Tucson, AZ
    Age
    51
    Posts
    1,133

    Re: Testing Radiator Pressure

    So I'm down to replacing the Graf water pump I just installed because I can't figure out what else could be causing my engine to run so hot since installing the Graf pump. FCP Euro has a new Behr pump which they say is OEM. https://www.fcpeuro.com/products/mer...p-1192001501-1. Nappervile MB offers a reman for twice that amount. http://www.mboemparts.com/?p=catalog...str=1192001501

    Any thoughts on why Napperville doesn't offer the new pump? Also, can anyone verify that the original pump is in fact Behr?
    Jon D.
    1994 E420
    1995 E420

  18. The Following User Says Thank You to emerydc8 For This Useful Post:

    TerryA (4 Weeks Ago)

  19. #10
    postwhore posterchild Klink's Avatar
    Join Date
    Feb 2014
    Location
    Abstract Plains, USA
    Posts
    3,570

    Re: Testing Radiator Pressure

    Yes, there is very little torque on the auxiliary fans at low speed.

    Water pumps can definitely make an engine run hot in the manner you describe. The impeller design may be incorrect. It may be pressed on to an incorrect depth. It could be pressed on backwards. It could have blades designed for a pump that rotates in the opposite direction. In that case, just as with any centrifugal pump or squirrel cage blower, the flow still runs in the correct direction, just much less efficiently.

    AFAIK, thermostats were not modified to increase flow, but they were definitely modified to be more reliable over the long term. The earlier version old school thermostat design is prone to cracking at the wax element, wearing itself off center, and sometimes just fracturing in a few places. A similar design to the late version 119 thermostat was introduced with the M120, the M111, and just about every other gasoline engine across the board. Curiously, the M104, which by Mercedes standards has a voracious appetite for thermostats, retaind the old-school design right up through the end of production. Generally, this won't mean much to any of us these days, because, as supplied to MB from the various thermostat vendors, usually Wahler, Behr, Behr-Thompson, all of the old school thermostats in the M119, which if you did not know, were all actually last version M116/117 thermostats, were also modified to be more durable, and they are vastly superior to the first version of this thermostat, many of which developed broken wax elements and failed by sticking closed, usually well before 100,000 miles. In Central Florida, a bunch of them failed in the warranty period. That's why there is an early version part number still in the EPC carrying the dreaded "do not use, no longer to be installed, etc." footnote.
    I have never seen a failure of the last version "everything is one piece with the cap" thermostat design, though I would definitely replace one of those also, when replacing the water pump, as I would with any thermostat design. And I would absolutely replace any thermostat may have been subjected to very hot coolant or steam.

    So, to shorten this up to what matters, I would always replace a thermostat when replacing the water pump regardless of its design or age. I would not bother to retrofit a late version water pump/thermostat assemblage. I would replace any thermostat on an engine that has run or is running hot regardless of the original reason for the hot running.

    Now, in the 124, you are pressed for space, but the thermostat is a piece of cake to change out in any other M119, so there is nothing stopping you from changing the thermostat first if there is any doubt. However, if you have access to a good digital/infrared thermometer, or perhaps even a contact thermometer that you could tape to the hoses, you could try this: When this thing is acting up and running hotter than high school love, check the temperature of the upper radiator hose and the lower radiator hoses. Especially with your auxiliary fans roaring away on high-speed, there should be a significant difference in temperature between the upper and lower radiator hoses if inadequate flow, either via defective thermostat, or defective pump is the issue.
    Putting the fun in dysfunction...

  20. The Following 5 Users Say Thank You to Klink For This Useful Post:

    500AMM (4 Weeks Ago), emerydc8 (4 Weeks Ago), gsxr (4 Weeks Ago), JC220 (4 Weeks Ago), TerryA (4 Weeks Ago)

  21. #11
    E500E Guru emerydc8's Avatar
    Join Date
    May 2011
    Location
    Tucson, AZ
    Age
    51
    Posts
    1,133

    Re: Testing Radiator Pressure

    Thanks, Klink. I already replaced the T-stat and no change. I don't have a digital thermometer (it's on my list) but I am pretty sure the radiator was fine when I flushed it last week and it's more a matter of the pump not flowing the volume it should.

    If it were you, would you get the new Behr or the reman from Napperville. Not sure how the reman can be twice the price of a new pump. Is Behr the OEM?
    Jon D.
    1994 E420
    1995 E420

  22. The Following User Says Thank You to emerydc8 For This Useful Post:

    TerryA (4 Weeks Ago)

  23. #12
    postwhore posterchild Klink's Avatar
    Join Date
    Feb 2014
    Location
    Abstract Plains, USA
    Posts
    3,570

    Re: Testing Radiator Pressure

    Quote Originally Posted by emerydc8 View Post
    Thanks, Klink. I already replaced the T-stat and no change. I don't have a digital thermometer (it's on my list) but I am pretty sure the radiator was fine when I flushed it last week and it's more a matter of the pump not flowing the volume it should.

    If it were you, would you get the new Behr or the reman from Napperville. Not sure how the reman can be twice the price of a new pump. Is Behr the OEM?
    I honestly don't know who the OEM is. The Behr branded unit is probably a safe bet, but I just don't know. Unless somebody else knows for certain, I would probably go with the stealer pump...
    Putting the fun in dysfunction...

  24. The Following 2 Users Say Thank You to Klink For This Useful Post:

    emerydc8 (4 Weeks Ago), TerryA (4 Weeks Ago)

  25. #13
    E500E Guru emerydc8's Avatar
    Join Date
    May 2011
    Location
    Tucson, AZ
    Age
    51
    Posts
    1,133

    Re: Testing Radiator Pressure

    Thanks, Klink. I'm out on a trip for a few weeks anyway, so maybe someone might know why the dealer is selling remans for twice what a new Behr costs. Considering the Graf is likely causing the heat issue, I don't want to replace one bad pump with another.
    Jon D.
    1994 E420
    1995 E420

  26. The Following User Says Thank You to emerydc8 For This Useful Post:

    TerryA (4 Weeks Ago)

  27. #14
    Site Honcho
    Klugscheisser
    Ich bekenne mich
    nicht schuldig.
    gerryvz's Avatar
    Join Date
    Nov 2008
    Location
    The Woodlands, Texas, USA
    Posts
    14,764

    Re: Testing Radiator Pressure

    I would be comfortable with Graf, Laso, Behr or OEMB water pumps, personally. I would prefer a new pump to a reman one, even though the "stealer" parts do carry a warranty.

  28. The Following 2 Users Say Thank You to gerryvz For This Useful Post:

    emerydc8 (4 Weeks Ago), TerryA (4 Weeks Ago)

  29. #15
    E500E Guru emerydc8's Avatar
    Join Date
    May 2011
    Location
    Tucson, AZ
    Age
    51
    Posts
    1,133

    Re: Testing Radiator Pressure

    I agree. A new one sounds better. It just seems too good to be true that a new one costs half as much as a reman. That makes me wonder if the reman is better and also what brand is the reman.
    Jon D.
    1994 E420
    1995 E420

  30. The Following User Says Thank You to emerydc8 For This Useful Post:

    TerryA (4 Weeks Ago)

  31. #16
    .036 Hoonigan™
    E500E Boffin
    gsxr's Avatar
    Join Date
    Dec 2008
    Location
    Boise, ID, USA
    Posts
    17,768

    Re: Testing Radiator Pressure

    I was not aware that Behr offered a water pump at all... I've only seen Laso, Graf, and maybe an oddball like Meyle or something. I'd be a bit nervous about Behr just because they have moved production for some items to China, and I'd be concerned about their water pump being a reboxed off-brand. In this case, given the misery of the job, I'd probably spring for the OE/dealer pump.

    Since you are already planning to replace the pump, it may not hurt to do the upgrade to the late-style, which requires a different upper water neck, one longer bolt for the different neck, different upper gasket (O-ring instead of paper), and different t-stat. I think this is documented in another forum thread?


  32. The Following 3 Users Say Thank You to gsxr For This Useful Post:

    500AMM (4 Weeks Ago), emerydc8 (4 Weeks Ago), vatc5637 (4 Weeks Ago)

  33. #17
    E500E Guru emerydc8's Avatar
    Join Date
    May 2011
    Location
    Tucson, AZ
    Age
    51
    Posts
    1,133

    Re: Testing Radiator Pressure

    Thanks, Dave. I will definitely consider that. Do you know why they went with the updated pump/thermostat housing? Did it flow more coolant? I know the thermostat flange is about an half inch larger but it still has to go through the same hose in the end.
    Jon D.
    1994 E420
    1995 E420

  34. #18
    .036 Hoonigan™
    E500E Boffin
    gsxr's Avatar
    Join Date
    Dec 2008
    Location
    Boise, ID, USA
    Posts
    17,768

    Re: Testing Radiator Pressure

    Jon, the late pump uses an M120 impeller part number, and there was speculation about increased flow vs the 'old' pump with M119 impeller p/n. However other than one anecdotal report from 10+ years ago on 500Ecstasy, there hasn't been much proof either way for any improvement in flow, temps, or cooling performance. The late pump eliminates the drain tube and drip-collection reservoir, likely as a cost-reduction effort. And as Klink described above, the late style t-stat may be slightly improved but that's not adequate reason to upgrade if the current pump is ok.

    I don't know who the OEM is on the pumps. The OE/dealer pumps don't have any brand name visible, just the MB Star and p/n, IIRC. There may be a logo that Klink or Jono could translate into a brand name?


  35. The Following 2 Users Say Thank You to gsxr For This Useful Post:

    500AMM (4 Weeks Ago), emerydc8 (4 Weeks Ago)

  36. #19
    E500E Guru emerydc8's Avatar
    Join Date
    May 2011
    Location
    Tucson, AZ
    Age
    51
    Posts
    1,133

    Re: Testing Radiator Pressure

    Thanks, Dave. So Klink would go with the stealer reman and GVZ would prefer the new Behr. What say ye?
    Jon D.
    1994 E420
    1995 E420

  37. #20
    E500 n00b nocfn's Avatar
    Join Date
    Jan 2014
    Location
    Kingwood TX
    Posts
    2,501

    Testing Radiator Pressure

    My laso boxed WP had a mb logo from
    Autohausaz for the C126.
    1994 E500
    249/275 - 8F19 or 8F32 or 8320

    1991 560 SEC
    199/268
    2014 E350 Cab 799/264

  38. The Following User Says Thank You to nocfn For This Useful Post:

    emerydc8 (4 Weeks Ago)

  39. #21
    E500E Guru emerydc8's Avatar
    Join Date
    May 2011
    Location
    Tucson, AZ
    Age
    51
    Posts
    1,133

    Re: Testing Radiator Pressure

    Thanks. I see Autohaus offers the Graf and Meyle pump for the 119 200 15 01.
    Jon D.
    1994 E420
    1995 E420

  40. #22
    E500E Guru
    Join Date
    Feb 2011
    Location
    DFW Texas
    Posts
    2,259

    Re: Testing Radiator Pressure

    I think you maybe running into the impeller is not pressed onto the bearing to the correct depth... heard of it on other models.. nothing 119 specific.

    M

  41. The Following 2 Users Say Thank You to samiam44 For This Useful Post:

    500AMM (4 Weeks Ago), emerydc8 (4 Weeks Ago)

  42. #23
    .036 Hoonigan™
    E500E Boffin
    gsxr's Avatar
    Join Date
    Dec 2008
    Location
    Boise, ID, USA
    Posts
    17,768

    Re: Testing Radiator Pressure

    Quote Originally Posted by emerydc8 View Post
    Thanks, Dave. So Klink would go with the stealer reman and GVZ would prefer the new Behr. What say ye?
    Per the previous concerns about Behr going Chinese... and how much fun this job is... I'd spring for the dealer reman.

    I am still surprised that the Graf pump may be defective!


  43. The Following User Says Thank You to gsxr For This Useful Post:

    emerydc8 (4 Weeks Ago)

  44. #24
    E500E Guru emerydc8's Avatar
    Join Date
    May 2011
    Location
    Tucson, AZ
    Age
    51
    Posts
    1,133

    Re: Testing Radiator Pressure

    Thanks guys. I will probably go with the reman from Napperville. At this point I don't know what else it could be. At least I don't have to remove the damper on my model.
    Jon D.
    1994 E420
    1995 E420

  45. #25
    E500E Guru
    Join Date
    Feb 2011
    Location
    DFW Texas
    Posts
    2,259

    Re: Testing Radiator Pressure

    I'm running a reman in my e500. Could there have been a change in the FC due to moving/storage on it's side etc?

    M

  46. #26
    E500E Guru emerydc8's Avatar
    Join Date
    May 2011
    Location
    Tucson, AZ
    Age
    51
    Posts
    1,133

    Re: Testing Radiator Pressure

    Not sure what you mean by FC.
    Jon D.
    1994 E420
    1995 E420

  47. #27
    E500E Guru
    Join Date
    Feb 2011
    Location
    DFW Texas
    Posts
    2,259

    Re: Testing Radiator Pressure

    Fan clutch

  48. #28
    E500E Guru emerydc8's Avatar
    Join Date
    May 2011
    Location
    Tucson, AZ
    Age
    51
    Posts
    1,133

    Re: Testing Radiator Pressure

    I don't think I even put the fan clutch on its side -- I leaned it up against a wall while I changed the pump. There was no leaking and it still passes the roar test. I'm almost certain it's the pump, but will have to wait a few weeks before I get to it.
    Jon D.
    1994 E420
    1995 E420

  49. #29
    E500E Guru
    Join Date
    Feb 2011
    Location
    DFW Texas
    Posts
    2,259

    Re: Testing Radiator Pressure

    Emercy,

    The one thing not mentioned frequently enough- MB stands behind their parts. So even with you installing it, it comes with a 1 year parts and *labor* warrentee. While I'm somewhat financially limited- cannot just dump thousands into my car at end, I am also time limited. So very seldom do I choose aftermarket parts. On a positive note, I find rework ussually goes much quicker. You'll find it much easier the 2nd time.


    Michael

  50. The Following 2 Users Say Thank You to samiam44 For This Useful Post:

    500AMM (4 Weeks Ago), emerydc8 (4 Weeks Ago)

  51. #30
    Site Honcho
    Klugscheisser
    Ich bekenne mich
    nicht schuldig.
    gerryvz's Avatar
    Join Date
    Nov 2008
    Location
    The Woodlands, Texas, USA
    Posts
    14,764

    Re: Testing Radiator Pressure

    I believe that MB factory parts now have a 2-year warranty, no?

    That said, with a water pump in particular I would never have a problem installing an aftermarket Laso (or Graf) water pump on any of my vehicles. If I remember correctly, on the former 1995 124 wagon I owned, there is a Laso water pump installed. I would also install Behr parts, such as a radiator, as I still think they are a good name. Not enough data (yet) on any quality drop on their parts, at least that I've seen.

    I did install a Nissens replacement radiator a few years back in my E500 and it has been fine. It was between a Nissens (which I got new for an excellent price), a Behr, or MB OE.

    For water pumps, I [personally] would always choose a Laso over a Graf, given a choice.

    Cheers,
    Gerry

  52. The Following 3 Users Say Thank You to gerryvz For This Useful Post:

    emerydc8 (4 Weeks Ago), nocfn (4 Weeks Ago), TerryA (2 Weeks Ago)

  53. #31
    E500E Guru emerydc8's Avatar
    Join Date
    May 2011
    Location
    Tucson, AZ
    Age
    51
    Posts
    1,133

    Re: Testing Radiator Pressure

    I ordered the factory reman from Napperville to be safe. When it comes, I'll see if there's any indication of who made it.
    Jon D.
    1994 E420
    1995 E420

  54. The Following 2 Users Say Thank You to emerydc8 For This Useful Post:

    gsxr (3 Weeks Ago), TerryA (2 Weeks Ago)

  55. #32
    E500E Guru emerydc8's Avatar
    Join Date
    May 2011
    Location
    Tucson, AZ
    Age
    51
    Posts
    1,133

    Re: Testing Radiator Pressure

    I just got the reman water pump from Napperville. The box is marked 119 200 15 01 80 but the pump is marked 119 201 07 01. Is this a superseded number? Also, it's hard to tell but it looks like the impeller is marked 119 201 00 37. Any thoughts on this?
    Attached Images Attached Images
    Last edited by emerydc8; 2 Weeks Ago at 02:21 AM.
    Jon D.
    1994 E420
    1995 E420

  56. The Following 3 Users Say Thank You to emerydc8 For This Useful Post:

    gerryvz (2 Weeks Ago), nocfn (2 Weeks Ago), TerryA (2 Weeks Ago)

  57. #33
    Site Honcho
    Klugscheisser
    Ich bekenne mich
    nicht schuldig.
    gerryvz's Avatar
    Join Date
    Nov 2008
    Location
    The Woodlands, Texas, USA
    Posts
    14,764

    Re: Testing Radiator Pressure

    The number on the box would be correct. It's very likely that the stamped part number you see is not available as a separate part from MB.

    It is not uncommon for individual parts that come in overall assemblies (such as a water pump, or an alternator, or a tandem pump, or a wiring harness, etc.), to have their own individual part numbers stamped on them, but these parts are not available separately ... they are only available as an entire assembly.

    So, for example an individual plastic end connector on a wiring harness may have an MB part number stamped on it, but it may be available ONLY as part of the assembled harness, NOT as an individual part. This is only an illustrative example.

    It's also very possible with a remanufactured part, that a core from an earlier (superseded) or related assembly, which fits correctly, is used as part of the reman. I think ultimately what matters is the number on the box -- assuming that the correct part was placed INTO the box

    Hope this helps,
    Cheers,
    Gerry

  58. The Following 2 Users Say Thank You to gerryvz For This Useful Post:

    emerydc8 (2 Weeks Ago), TerryA (2 Weeks Ago)

  59. #34
    .036 Hoonigan™
    E500E Boffin
    gsxr's Avatar
    Join Date
    Dec 2008
    Location
    Boise, ID, USA
    Posts
    17,768

    Re: Testing Radiator Pressure

    Gerry is correct. The number on the pump is for the main casting, not the assembly. The EPC shows the complete assembly number, which will not be anywhere on the pump, only on the box. Same thing applies to cylinder heads, differentials, steering boxes, and a bunch of other items.

    The pump p/n you have (119-200-15-01) is the early style so I would expect it has the 119 impeller. (The late pump is p/n 119-200-21-01).


  60. The Following 2 Users Say Thank You to gsxr For This Useful Post:

    emerydc8 (2 Weeks Ago), TerryA (2 Weeks Ago)

  61. #35
    E500E Guru emerydc8's Avatar
    Join Date
    May 2011
    Location
    Tucson, AZ
    Age
    51
    Posts
    1,133

    Re: Testing Radiator Pressure

    Thanks, guys. I will install it this weekend and see if it corrects the running hot problem.
    Jon D.
    1994 E420
    1995 E420

  62. The Following 2 Users Say Thank You to emerydc8 For This Useful Post:

    gsxr (2 Weeks Ago), TerryA (2 Weeks Ago)

Similar Threads

  1. The upper radiator hose has high pressure !!
    By Mercedes only in forum M119 Engine
    Replies: 24
    Last Post: 04-15-2016, 08:11 AM
  2. Software to Defeat Emissions Testing
    By maw1124 in forum Off-Topic Discussions
    Replies: 22
    Last Post: 02-28-2016, 04:32 PM
  3. Airbag testing
    By gsxr in forum Off-Topic Discussions
    Replies: 7
    Last Post: 09-29-2015, 10:25 PM
  4. Emission testing : Failed, NOX and CO2 out of range..?
    By samiam44 in forum Troubleshooting and Diagnostics
    Replies: 20
    Last Post: 12-18-2011, 07:51 PM
  5. HOT ROD Magazine article on dyno testing
    By gerryvz in forum High-Performance Modifications
    Replies: 7
    Last Post: 07-22-2011, 12:54 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •