Results 1 to 12 of 12

Thread: Newly installed SA - Excessive pedal play and poor performance

  1. #1
    Member
    Join Date
    Jun 2016
    Location
    Horseshoe Bay, BC
    Posts
    51

    Newly installed SA - Excessive pedal play and poor performance

    Hi All:
    Just had front brakes replaced with used SA calipers and new rotors on my 1992 500e Euro along with new LCAs. I left the rear brakes and calipers stock. Much to my dismay I now find the braking to be worse than before. There is excessive pedal movement ~ 3/4 of total travel and braking is poor. I have to pump the pedal and even in doing this the car barely stops.

    I did not have this condition with the old brakes. Is this a symptom of the master cylinder seals going? I had read that the master cylinder is sufficiently large to accommodate the SA larger caliper but given the poor performance maybe that's the fix.

    Any help with diagnostics or suggestions appreciated!


    All the best,

    Joe
    1992 500E Euro
    1993 928 GTS

  2. #2
    E500E Guru
    Join Date
    Feb 2012
    Posts
    778

    Re: Newly installed SA - Excessive pedal play and poor performance

    Might still have air in the system

  3. #3
    Senior Member doolar's Avatar
    Join Date
    Oct 2013
    Location
    Malmö, Sweden
    Age
    42
    Posts
    481

    Re: Newly installed SA - Excessive pedal play and poor performance

    Air in the system would be the first thing I'd check. If you have a pocket left in one or both of the calipers you will experience what you do. Bleed, bleed, bleed and bleed some more. I think I went through two litres worth of brake fluid when I did this work, both front and rear.

    When I swapped to the SA kit I had a totally opposite experience. I used the original master cylinder, and my brakes where notably better from the start.
    Thomas
    1994 E420
    1993 500E - (my fathers)

  4. #4
    .036 Hoonigan™
    E500E Boffin
    gsxr's Avatar
    Join Date
    Dec 2008
    Location
    Boise, ID, USA
    Posts
    18,715

    Re: Newly installed SA - Excessive pedal play and poor performance

    It sounds like the system is not properly bled. Did you use a pressure bleeder with 2 bar / 30psi of pressure, and after bleeding all 4 calipers also bleed port SP with the engine running? If so, it COULD be the MC seals... but I'd bleed again (pull at least 150cc from each caliper, doesn't hurt to use more) before condemning other components. What you describe is something with the hydraulic system, not the calipers themselves.

    Pedal travel should be very similar to stock brakes, most people probably would never notice a difference (assuming similar pad compounds).

    Dave M.
    1997 E420 (Bugeyes)
    1994 E420 (Blondie)
    1994 E500 (Q-ship)
    1992 500E (Mach 5)
    1987 300D (Sportline Stage 2)
    Click here for my website
    Click here for my YouTube channel

  5. #5
    Member
    Join Date
    Jun 2016
    Location
    Horseshoe Bay, BC
    Posts
    51

    Re: Newly installed SA - Excessive pedal play and poor performance

    Quote Originally Posted by alabbasi View Post
    Might still have air in the system
    Thanks! Yes I thought so but was assured that system was bleed. Will re-bleed.

    Quote Originally Posted by doolar View Post
    Air in the system would be the first thing I'd check. If you have a pocket left in one or both of the calipers you will experience what you do. Bleed, bleed, bleed and bleed some more. I think I went through two litres worth of brake fluid when I did this work, both front and rear.

    When I swapped to the SA kit I had a totally opposite experience. I used the original master cylinder, and my brakes where notably better from the start.
    Thanks, I will re-bleed!

    Quote Originally Posted by gsxr View Post
    It sounds like the system is not properly bled. Did you use a pressure bleeder with 2 bar / 30psi of pressure, and after bleeding all 4 calipers also bleed port SP with the engine running? If so, it COULD be the MC seals... but I'd bleed again (pull at least 150cc from each caliper, doesn't hurt to use more) before condemning other components. What you describe is something with the hydraulic system, not the calipers themselves.

    Pedal travel should be very similar to stock brakes, most people probably would never notice a difference (assuming similar pad compounds).

    Thanks GSRX ! Not sure if the rears were bleed as only changed the front calipers. I'll do then too. BTW, what is SP and where is it located? Why does this need to be done with the engine running?

    All the best,

    Joe
    1992 500E Euro
    1993 928 GTS

  6. The Following User Says Thank You to JCM1 For This Useful Post:

    gsxr (06-22-2017)

  7. #6
    .036 Hoonigan™
    E500E Boffin
    gsxr's Avatar
    Join Date
    Dec 2008
    Location
    Boise, ID, USA
    Posts
    18,715

    Re: Newly installed SA - Excessive pedal play and poor performance

    Joe, it's part of the factory procedure for ASR. The start of the procedure involves releasing pressure from the SP port, then bleeding all 4 calipers, and finally starting the engine and bleeding SP port. You definitely need to bleed all 4 calipers and the SP port to get the system working correctly.

    Link to FSM procedure, see page 2 / section B:
    http://w124-zone.com/downloads/MB%20...94_95/4280.pdf


  8. The Following User Says Thank You to gsxr For This Useful Post:

    wf758 (06-24-2017)

  9. #7
    Member
    Join Date
    Jun 2016
    Location
    Horseshoe Bay, BC
    Posts
    51

    Re: Newly installed SA - Excessive pedal play and poor performance

    Thanks GSRX! I'll check to see if the mechanic used this procedure and if not I'll get it done.

    All the best,

    Joe
    1992 500E Euro
    1993 928 GTS

  10. The Following User Says Thank You to JCM1 For This Useful Post:

    gsxr (06-22-2017)

  11. #8
    .036 Hoonigan™
    E500E Boffin
    gsxr's Avatar
    Join Date
    Dec 2008
    Location
    Boise, ID, USA
    Posts
    18,715

    Re: Newly installed SA - Excessive pedal play and poor performance

    Joe, also double-check that your mechanic is pressure bleeding, and not pumping the pedal.

    ASR cars are not happy unless they are pressure bled per factory procedure.


  12. #9
    E500E Guru
    Join Date
    Feb 2012
    Posts
    778

    Re: Newly installed SA - Excessive pedal play and poor performance

    My 560SEC has ASR and was a giant pain in the rear to bleed

  13. #10
    E500E Guru captruff's Avatar
    Join Date
    Jul 2009
    Location
    Orange County
    Posts
    1,470

    Re: Newly installed SA - Excessive pedal play and poor performance

    After I installed my rebuilt SA calipers, I re bleed the system 3 additional times at 500, 1000, and again at 1,500 miles....brake fluid is not that expensive and bleeding brake is fairly easy. +1 on air in system

    Jeff
    "Nice Things Cost Money" - Oskar Schindler

  14. The Following User Says Thank You to captruff For This Useful Post:

    wf758 (06-24-2017)

  15. #11
    Senior Member Rouven036's Avatar
    Join Date
    Oct 2009
    Location
    Middle East / Germany
    Posts
    482

    Re: Newly installed SA - Excessive pedal play and poor performance

    +2 on air in the system.
    W123, W124, R129, W163, W201, R230

  16. The Following User Says Thank You to Rouven036 For This Useful Post:

    wf758 (06-24-2017)

  17. #12
    Site Honcho
    Klugscheisser
    Ich bekenne mich
    nicht schuldig.
    gerryvz's Avatar
    Join Date
    Nov 2008
    Location
    The Woodlands, Texas, USA
    Posts
    15,502

    Re: Newly installed SA - Excessive pedal play and poor performance

    Any update on this? Did re-bleeding solve the issue?

Similar Threads

  1. Rear Suspension - excessive negative camber?
    By ffinn in forum Brakes, Suspension and Steering
    Replies: 7
    Last Post: 03-12-2017, 07:54 AM
  2. 2x18x9 AMG Monoblocks, newly refinished
    By herb5998 in forum Parts for Sale
    Replies: 1
    Last Post: 08-01-2015, 08:54 AM
  3. Driving Newly Purchased Car Home
    By Melville in forum Off-Topic Discussions
    Replies: 34
    Last Post: 04-28-2015, 10:14 PM
  4. FS: OE MB pedal cover kit
    By Jimbo in forum Parts for Sale
    Replies: 8
    Last Post: 10-08-2013, 06:20 AM
  5. steering play
    By bing in forum Brakes, Suspension and Steering
    Replies: 1
    Last Post: 12-05-2010, 06:46 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •