Results 1 to 7 of 7

Thread: Strange problem on acceleration!

  1. #1
    Member Swe500E's Avatar
    Join Date
    Jan 2010
    Location
    Sweden, Europe
    Age
    31
    Posts
    46

    Strange problem on acceleration!

    A friend came past me yesterday with his early 1991 500e to ask about a problem he had with his car.
    With kickdown or normal acceleration, it does not want to exceed 5500 rpm.
    Its like a rpm stop.
    Which also means that it does not want to shift to a higher gear on kickdown.

    He has had the car on troubleshooting and they suspect it's this one



    http://imgur.com/a/9W8py

    When I look at the number, it seems that it comes from a w140?
    And it looks quite different when compared to those in my 500E and E420.

    The car goes well otherwise, idle silky smooth, accelerates without a doubt.
    Switch gears without slipning or slaming the gear.

    The only known fault is that the cruise control does not work at all.

    A few years ago the gearbox was refurbished, the upper wireharness was replaced and also distributor caps.
    The workshop has read error codes but I dont not know if it gave something.
    Attached Images Attached Images
    Last edited by Swe500E; 5 Days Ago at 01:02 AM.
    E420 -94 481 Bornit
    W123 230 1980 930 silberblau
    E220 CDI -08 S211

  2. #2
    .036 Hoonigan™
    E500E Boffin
    gsxr's Avatar
    Join Date
    Dec 2008
    Location
    Boise, ID, USA
    Posts
    18,318

    Re: Strange problem on acceleration!

    That EZL is normal for a very early build 500E (like, 1990-1991). We need to know the error codes to diagnose further. My guess is the NSS (neutral safety switch / starter lockout).

    BTW, for the cruise control not working, check the part number of the E-GAS module. If it's a W140 unit, that would explain the dead cruise. Otherwise, the switch (stalk on the steering column) miiiight be bad.

    Dave M.
    1997 E420 (Bugeyes)
    1994 E420 (Blondie)
    1994 E500 (Q-ship)
    1992 500E (Mach 5)
    1987 300D (Sportline Stage 2)
    Click here for my website
    Click here for my YouTube channel

  3. #3
    Member Swe500E's Avatar
    Join Date
    Jan 2010
    Location
    Sweden, Europe
    Age
    31
    Posts
    46

    Re: Strange problem on acceleration!

    So you think the ezl is not the problem?

    The nss, how does it work?
    Isnt that only to make the engine not start when in a gear?

    Is it posible to take the ezl unit from my 92 500e and test if it works better with that one?
    Attached Images Attached Images
    Last edited by Swe500E; 5 Days Ago at 09:13 AM.
    E420 -94 481 Bornit
    W123 230 1980 930 silberblau
    E220 CDI -08 S211

  4. #4
    .036 Hoonigan™
    E500E Boffin
    gsxr's Avatar
    Join Date
    Dec 2008
    Location
    Boise, ID, USA
    Posts
    18,318

    Re: Strange problem on acceleration!

    Quote Originally Posted by Swe500E View Post
    So you think the ezl is not the problem?
    I seriously doubt it. That car (WDB1240361B446904) is very early build, about Jan-1991!
    https://www.datamb.com/vin/q8vKkQA8RyKEyprWo


    Quote Originally Posted by Swe500E View Post
    The nss, how does it work? Isnt that only to make the engine not start when in a gear?
    No. It also sends a gear position indicator to the computers. If the computers think the transmission is in park or neutral, it COULD cause a problem like this. However, there would normally be an error code on the E-GAS module.


    Quote Originally Posted by Swe500E View Post
    Is it posible to take the ezl unit from my 92 500e and test if it works better with that one?
    According to the EPC, no. The later EZL also requires later / new-style coils.


  5. #5
    Member Swe500E's Avatar
    Join Date
    Jan 2010
    Location
    Sweden, Europe
    Age
    31
    Posts
    46

    Re: Strange problem on acceleration!

    Thank you very much!
    I'll follow up with how it goes!

    Nss, the car does not start on D or R, only in P and N.
    But it can be bad anyway?
    E420 -94 481 Bornit
    W123 230 1980 930 silberblau
    E220 CDI -08 S211

  6. #6
    .036 Hoonigan™
    E500E Boffin
    gsxr's Avatar
    Join Date
    Dec 2008
    Location
    Boise, ID, USA
    Posts
    18,318

    Re: Strange problem on acceleration!

    Quote Originally Posted by Swe500E View Post
    Thank you very much!
    I'll follow up with how it goes!

    Nss, the car does not start on D or R, only in P and N.
    But it can be bad anyway?
    Yes - the starter lockout is separate from the gear position indicators, so the car starting in P/N doesn't mean the switch is ok. If the switch is indicating an implausible gear position, this will trigger codes, and you can also view the live data (gear indicated) with a Star SDS system.


  7. #7
    Member Swe500E's Avatar
    Join Date
    Jan 2010
    Location
    Sweden, Europe
    Age
    31
    Posts
    46

    Re: Strange problem on acceleration!

    Yesterday he tried to Chang nss, but the problem still persists.
    He will leave the car at another workshop and get error codes read.
    To be continued...
    E420 -94 481 Bornit
    W123 230 1980 930 silberblau
    E220 CDI -08 S211

  8. The Following User Says Thank You to Swe500E For This Useful Post:

    gsxr (1 Day Ago)

Similar Threads

  1. Strange short test result
    By E500star in forum M119 Engine
    Replies: 2
    Last Post: 3 Weeks Ago, 12:46 PM
  2. Strange and mild lumpy idle
    By Dbreid in forum Troubleshooting and Diagnostics
    Replies: 85
    Last Post: 05-12-2017, 08:15 AM
  3. Strange Groaning from Front End
    By brock in forum Brakes, Suspension and Steering
    Replies: 9
    Last Post: 12-16-2015, 09:54 PM
  4. A/C Blower Fan Slows on Acceleration
    By emerydc8 in forum Heating and Cooling
    Replies: 0
    Last Post: 09-04-2012, 10:04 PM
  5. Strange car for sale in Germany
    By 036 in forum Cars for Sale - 500E / E500 ONLY
    Replies: 5
    Last Post: 07-15-2011, 07:31 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •