Results 1 to 1 of 1

Thread: Trip and Odometer Not Working

  1. #1
    Junior Member
    Join Date
    Apr 2014
    Location
    Los Angeles, CA
    Posts
    15

    Trip and Odometer Not Working

    My trip meter and odometer stopped working on my 1993 400E with 192,100 miles. Found a small black gear that broke so I ordered a new one. My buddy installed the new gear but during the test drive, a tooth broke off from a larger gear. Ended up buying an odometer gear set and once that was installed, my odometer is now finally working again. Do not just order the one gear and I recommend getting the entire gear set. I bought the odometer gear set from https://store.garagistic.com/odomete...dometer-repair
    Attached Images Attached Images
    Last edited by FalconOps; 6 Days Ago at 10:12 PM.

  2. The Following 3 Users Say Thank You to FalconOps For This Useful Post:

    gsxr (1 Week Ago), Kip (1 Week Ago), Stevester 500E (6 Days Ago)

Similar Threads

  1. HOW-TO: Replacing Odometer Gears
    By emerydc8 in forum "HOW-TO" Tutorial Articles
    Replies: 40
    Last Post: 07-13-2017, 07:53 AM
  2. Odometer quit after I reset the trip?
    By Ascension in forum Troubleshooting and Diagnostics
    Replies: 11
    Last Post: 12-05-2014, 10:31 PM
  3. Odometer not working
    By Stevester 500E in forum Transmission and Driveline
    Replies: 0
    Last Post: 08-22-2014, 04:38 PM
  4. Odometer repair
    By gerryvz in forum Electrical, CAN and Wiring
    Replies: 6
    Last Post: 10-22-2012, 11:50 AM
  5. odometer - sold :-)
    By Rudy in forum Parts for Sale
    Replies: 0
    Last Post: 02-20-2011, 02:51 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •