Results 1 to 1 of 1

Thread: Issue - CHECK ENGINE light & blink code #4

  1. #1

    Issue - CHECK ENGINE light & blink code #4

    Postby gerryvz on Mon Dec 01, 2008 5:25 am

    Question for anyone -- my E500 does, on very rare occasions, give me a check engine light with a blink code of 4. It has only done this four or five times over the past year, so it's very intermittent, and it doesn't affect the running of the car at all.

    I translated the code last summer (my MB books & diagnostic info are currently in storage until we buy a new house) and code #4 was something along the lines of insufficient voltage provided to ???

    Has anyone gotten a code 4, and/or have a remedy for what it could be?

    Thanks,
    Gerry

    ===================================

    Postby Glen on Mon Dec 01, 2008 5:41 am

    Code 4 on the DM is: air injection system faulty

    My wife's wagon had this code a while ago, it was one of the vacuum powered switchover valves for the egr system.

    See page 35 in the attachment...hmm, can't attach it.

    Here's a link to a .pdf on my website: http://cars.tokuhara.net/cars/misc/cs1000_mb.pdf

    Glen Tokuhara
    A few cars...

    ===================================

    Postby gerryvz on Mon Dec 01, 2008 5:49 am

    Thanks Glen - I'll check it out. Sounds feasible.

    Only EGR issue I've ever had is the semi-famous "carbon-blocked EGR tube" on the M104 engines, but that can be reamed out pretty easily.

    Also I will check out WTF the problem is with attachments. You should be able to attach as I enabled that function, and provided extra-big doc sizes (I think it is 2MB). Looks like your doc is only around 900K so

    Teething issues ...

    cs1000_mb.pdf
    You do not have the required permissions to view the files attached to this post.

    ===================================

    Postby 550Maranello on Mon Dec 01, 2008 3:01 pm

    Hi Gerry,

    It happened to me too. Last week, prior to our trip to New Haven, I took my car to the mechanic. He said there were too many codes and decided to clean them all to see if that solves the problem. He also installed front and rear Porterfield RS4 brake pads.

    Regards,

    Orazio

    ===================================

    Postby gerryvz on Mon Dec 01, 2008 3:53 pm

    Hi Orazio,

    Yes, I've pulled/cleared codes several times over the past year. There are several codes that my car consistently gets from time to time which never trigger a CE light -- my mechanic has always told me that these codes are typical/normal and really not anything to worry about, and that they see them on many if not most cars.

    The code #4 is definitely the one tripping the CE light. I'm not totally stressed out about it because it's so rare in happening, but after the third time it's made me resolve to get it taken care of.

    Let us know what happens with your mechanic and the codes that he found/cleared.

    Cheers,
    Gerry
    Attached Files Attached Files

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •