Results 1 to 15 of 15

Thread: New 500E Owner with ASR/ABS Light/ Cruise Control failure and weird issue under hard acceleration

  1. #1
    Member
    Join Date
    Dec 2013
    Location
    Aubrey, Texas
    Posts
    30

    New 500E Owner with ASR/ABS Light/ Cruise Control failure and weird issue under hard acceleration

    I just purchased a 1992 500E out of Tucson AZ. Auto Transport delivered it yesterday. My buddy has had a couple of 500E's over the years and I have been watching.

    This one rolled off the truck last night. The ASR light is on and the ABS Light is on. Under hard acceleration the car will just shut down but comes right back when I let off the gas. Under normal driving conditions everything seems to be fine.

    I don't have a tool to pull the codes yet. I tried the ebay link from a previous post - but the tool was gone.

    Anyone ever had that type of issue under hard acceleration?

    Thanks,

  2. #2
    .036 Hoonigan™
    E500E Boffin
    gsxr's Avatar
    Join Date
    Dec 2008
    Location
    Boise, ID, USA
    Posts
    18,848

    Re: New 500E Owner with ASR/ABS Light/ Cruise Control failure and weird issue under hard acceleration

    Welcome aboard.

    Did you get the black/black one here, or the black/cream one here? Both were for sale in Tucson recently.

    ASR and ABS lights both on sounds like "limp home mode" to me. You can't tell much without the code reader (click here for a current eBay listing). Toss the paperwork that comes with the code reader, and use the PDF file linked in this post instead.

    First things I would check are the date codes on both the upper engine harness, and the ETA. Most common causes of limp mode are a bad ETA or a bad NSS (neutral safety / starter lockout switch). If the ETA is original, it's a prime suspect. Instructions on how to check the date codes for both the harness and ETA are in the forum Wiki:
    https://www.500eboard.com/forums/showwiki.php


    Dave M.
    1997 E420 (Bugeyes)
    1994 E420 (Blondie)
    1994 E500 (Q-ship)
    1992 500E (Mach 5)
    1987 300D (Sportline Stage 2)
    Click here for my website
    Click here for my YouTube channel

  3. #3
    Member
    Join Date
    Dec 2013
    Location
    Aubrey, Texas
    Posts
    30

    Re: New 500E Owner with ASR/ABS Light/ Cruise Control failure and weird issue under hard acceleration

    It was the black/cream one. My buddy Jay Walker has a grey one and previously had a black one. I have a 94 E420 as well that is in excellent condition. The wiring harness was replaced in 2000 by a Mercedes Dealership. The car came with a two inch stack of maintenance history/receipts and the original sales contract.

    I just purchased the scanner. Is it OK to drive in LH mode. The E420 is getting seat recovered but I also have a Ford Excursion and a 72 VW Beetle I could drive for the time being.

  4. #4
    Member
    Join Date
    Dec 2013
    Location
    Aubrey, Texas
    Posts
    30

    Re: New 500E Owner with ASR/ABS Light/ Cruise Control failure and weird issue under hard acceleration

    I'll check the receipts for the ETA.

  5. #5
    Site Admin
    auto enthusiast...
    Glen's Avatar
    Join Date
    Jul 2009
    Location
    Carlsbad, CA USA
    Posts
    2,661

    Re: New 500E Owner with ASR/ABS Light/ Cruise Control failure and weird issue under hard acceleration

    Welcome to the board! You've come to the right place to enjoy, maintain, and keep your new ride.
    '94 E500 (744) | '94 E500 (199)         Misc. snapshots

  6. #6
    E500E Guru texas993's Avatar
    Join Date
    Aug 2013
    Location
    Dallas TX
    Posts
    504

    Re: New 500E Owner with ASR/ABS Light/ Cruise Control failure and weird issue under hard acceleration

    Welcome Philip! Good luck with diagnosing your problems. There is some E500E knowledge in Dallas that may be able to help too (I'm thinking of "samiam"). Additionally, Gerry (site guru) will be in Dallas this weekend.

    If it comes to swapping out modules in the CAN box, I just picked a bunch up from junkyards and may have one that you can test with.

    Just let me (us) know what we can do to help! I am not an expert as I have only had my car for a couple of months. But I am learning!
    Patrick
    1987 560SL (Current Project Car)
    1995 E300D, 2005 G500
    1997 Porsche 993 C2S, 2011 Porsche Cayenne Turbo
    1993 500E Signal Red / Black SOLD

  7. #7
    Member
    Join Date
    Dec 2013
    Location
    Aubrey, Texas
    Posts
    30

    Re: New 500E Owner with ASR/ABS Light/ Cruise Control failure and weird issue under hard acceleration

    Thanks Patrick. I'm up the road in Denton. I would like to have lunch/coffee with y'all sometime soon.

  8. #8
    "Nit-Picky and
    Bitter Mechanic"
    jhodg5ck's Avatar
    Join Date
    Jul 2009
    Location
    Lilburn, GA
    Posts
    1,966

    Re: New 500E Owner with ASR/ABS Light/ Cruise Control failure and weird issue under hard acceleration

    I would check that stack of records to see if the throttle actuator has been done. If not, I'd be mighty suspect.

    Jonathan
    Blue Ridge Mercedes Jonathan Hodgman
    Mercedes Repair Atlanta
    http://www.blueridgemb.com/
    08 E63 05 E55 Estate 95 S600 94 SL700 93 500E Brumos/RTech 92 500E T/R 93 500E (122)
    91 560SEC ECE 87 Hammer Coupe, Sedan and Wagon 6.0L 32V 86 560SEL AMG 6.0L 32V

  9. #9
    E500E Guru
    Join Date
    Feb 2011
    Location
    DFW Texas
    Posts
    2,417

    Re: New 500E Owner with ASR/ABS Light/ Cruise Control failure and weird issue under hard acceleration

    I'm local too=)


    There are a bunch of us meeting on Saturday( I think).

    Michael

  10. #10
    Senior Member txbrit's Avatar
    Join Date
    Sep 2013
    Location
    Grapevine, TX
    Posts
    179

    Re: New 500E Owner with ASR/ABS Light/ Cruise Control failure and weird issue under hard acceleration

    Welcome Philip,

    I am in Grapevine - but am either traveling - indeed I will be out of town this coming weekend when everyone else in town - or more recently busy being sick

    But I am sure the growing Texas "contingent" will all get together sometime in 2014

    Hope you get things fixed - as you can see there is plenty of people here willing to help!

    David.
    Connecting via two tin cans and a piece of string
    Currently in the Garage....

    92 500E
    08 GL450 - RIP - shopping replacement
    96 Bentley Continental R

  11. #11
    I do believe...! Christian_K's Avatar
    Join Date
    Aug 2010
    Location
    Dieburg - Germany
    Age
    33
    Posts
    1,427

    Re: New 500E Owner with ASR/ABS Light/ Cruise Control failure and weird issue under hard acceleration

    Hi and welcome, good luck finding the ABS+ASR issue.
    I haven't find mine since months.
    Christian K.
    06/1992 500E - DB199 Blauschwarz-Metallic
    09/1989 300E - DB172 Anthrazitgrau-Metallic
    11/1998 E430 - DB339 Violan-Metallic
    06/2003 CL55 AMG KOMPRESSOR - DB197 Obsidianschwarz-Metallic


  12. #12
    Member
    Join Date
    Dec 2013
    Location
    Aubrey, Texas
    Posts
    30

    Re: New 500E Owner with ASR/ABS Light/ Cruise Control failure and weird issue under hard acceleration

    Where are the DFW guys meeting on Saturday. I'm free till about 3:00pm.
    Philip Mack
    1992 500E
    1994 E420
    1972 VW Bug
    2003 Ford Excursion Diesel

  13. #13
    I do believe...! Christian_K's Avatar
    Join Date
    Aug 2010
    Location
    Dieburg - Germany
    Age
    33
    Posts
    1,427

    Re: New 500E Owner with ASR/ABS Light/ Cruise Control failure and weird issue under hard acceleration

    Was there any results?
    Christian K.
    06/1992 500E - DB199 Blauschwarz-Metallic
    09/1989 300E - DB172 Anthrazitgrau-Metallic
    11/1998 E430 - DB339 Violan-Metallic
    06/2003 CL55 AMG KOMPRESSOR - DB197 Obsidianschwarz-Metallic


  14. #14
    Junior Member
    Join Date
    Nov 2013
    Location
    Spain
    Age
    52
    Posts
    11

    Re: New 500E Owner with ASR/ABS Light/ Cruise Control failure and weird issue under hard acceleration

    Hi,

    My friend , I had the same problem, some old russian mecanic expert told me to remove the battery pad. I did it and now is ok.

    regards

    Shah Kar

  15. #15
    I do believe...! Christian_K's Avatar
    Join Date
    Aug 2010
    Location
    Dieburg - Germany
    Age
    33
    Posts
    1,427

    Re: New 500E Owner with ASR/ABS Light/ Cruise Control failure and weird issue under hard acceleration

    Quote Originally Posted by Shah Kar View Post
    Hi,

    My friend , I had the same problem, some old russian mecanic expert told me to remove the battery pad. I did it and now is ok.

    regards

    Shah Kar
    Hi,
    what is the battery pad?
    Thank alot.

    Christian K.
    06/1992 500E - DB199 Blauschwarz-Metallic
    09/1989 300E - DB172 Anthrazitgrau-Metallic
    11/1998 E430 - DB339 Violan-Metallic
    06/2003 CL55 AMG KOMPRESSOR - DB197 Obsidianschwarz-Metallic


Similar Threads

  1. Replies: 21
    Last Post: 10-06-2013, 01:47 AM
  2. Cruise control issue
    By Uberwagon in forum Electrical, CAN and Wiring
    Replies: 3
    Last Post: 09-09-2013, 02:05 PM
  3. HOW TO: Trunk Light Control Tip
    By DerFuror in forum "HOW-TO" Tutorial Articles
    Replies: 12
    Last Post: 08-25-2011, 10:55 PM
  4. Cruise Control Failing
    By Benzer in forum Electrical, CAN and Wiring
    Replies: 6
    Last Post: 05-01-2011, 09:15 PM
  5. Issue - CHECK ENGINE light & blink code #4
    By 500Espot in forum De-Coding
    Replies: 0
    Last Post: 07-11-2009, 09:26 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •