Results 1 to 9 of 9

Thread: Weird electrical issue today with my gas guage???

  1. #1
    E420 Guru Ascension's Avatar
    Join Date
    Jul 2014
    Location
    Birmingham Alabama
    Age
    59
    Posts
    914

    Weird electrical issue today with my gas guage???

    Every thing seemed fine then suddenly while sitting at a red light I see the gas gauge drop 1/4 of a tank and start shuddering like crazy. I'm like WTF?? As soon as I release the brakes it jumps right back to where it was and is normal so??? Rest of the trip it was normal but that kinda freaked me out.
    Looked over the brake lights and there is some damage to the 3rd light where it looks like it over heated and melted but it's been there since I have owned this car and all the lights appear to be working normally.
    WTF would cause the gas gauge to suddenly drop and dance like that they straighten up as soon as I release the brakes cauze I don't have a clue here??? Freaked me out badly enough that I turned around and took her home and now can't find squat to account for this.
    "Where justice is denied, where poverty is enforced, where ignorance prevails, and where any one class is made to feel that society is an organized conspiracy to oppress, rob and degrade them, neither persons nor property will be safe." Frederick Douglass

  2. #2
    E500 Apprentice Guru
    Banzworld Ambassador
    nocfn's Avatar
    Join Date
    Jan 2014
    Location
    Kingwood TX
    Posts
    2,893

    Re: Weird electrical issue today with my gas guage???

    i have seen similar stuff iin the cluster, searching for ground. Bad brake switch, or loose grounds behind the cluster, above the sunroof switch. I had a similar issue with bouncing needles in my C126 when stopping in the rain, with fogs and headlamps on with wipers running. it was the brakelight switch for me, and the 3rd brakelight went out as well. coincidence?
    1994 E500
    249/275 - 8F19 or 8F32 or 8320

    1991 560 SEC
    199/268
    2014 E350 Cab 799/264

  3. #3
    postwhore posterchild Klink's Avatar
    Join Date
    Feb 2014
    Location
    Abstract Plains, USA
    Posts
    3,661

    Re: Weird electrical issue today with my gas guage???

    I'm not near a wiring diagram but IIRC, the fuel tank sensor unit and one or both of the tail lights share a chassis ground connection. It probably needs to be taken apart and cleaned up. Hairline cracks and/or corroded ends on the fuses can give you this kind of stuff too. If the problem is on the rear lamp ground circuit, do not be surprised if your cruise control stops working until the next key cycle as well. That does not have to happen, but it often does if there is any fault on the brake lamp circuit.
    Putting the fun in dysfunction...

  4. The Following 2 Users Say Thank You to Klink For This Useful Post:

    Ascension (07-18-2015), nocfn (07-18-2015)

  5. #4
    E420 Guru Ascension's Avatar
    Join Date
    Jul 2014
    Location
    Birmingham Alabama
    Age
    59
    Posts
    914

    Re: Weird electrical issue today with my gas guage???

    Quote Originally Posted by Klink View Post
    I'm not near a wiring diagram but IIRC, the fuel tank sensor unit and one or both of the tail lights share a chassis ground connection. It probably needs to be taken apart and cleaned up. Hairline cracks and/or corroded ends on the fuses can give you this kind of stuff too. If the problem is on the rear lamp ground circuit, do not be surprised if your cruise control stops working until the next key cycle as well. That does not have to happen, but it often does if there is any fault on the brake lamp circuit.
    Replaced all of those little fuses a few months ago with new copper strip fuses so that likely is not the culprit>

    Any idea where that ground you are talking about is brother??
    BTW still owe you lunch you at MBBH on Monday?
    "Where justice is denied, where poverty is enforced, where ignorance prevails, and where any one class is made to feel that society is an organized conspiracy to oppress, rob and degrade them, neither persons nor property will be safe." Frederick Douglass

  6. #5
    postwhore posterchild Klink's Avatar
    Join Date
    Feb 2014
    Location
    Abstract Plains, USA
    Posts
    3,661

    Re: Weird electrical issue today with my gas guage???

    IIRC, it is a relatively large multiple ground point, 10 mm bolt head, on a bracket extending down from the left C-pillar. just kind of below and inside from the radio antenna...
    Putting the fun in dysfunction...

  7. The Following 2 Users Say Thank You to Klink For This Useful Post:

    Ascension (07-19-2015), TerryA (07-18-2015)

  8. #6
    E420 Guru Ascension's Avatar
    Join Date
    Jul 2014
    Location
    Birmingham Alabama
    Age
    59
    Posts
    914

    Re: Weird electrical issue today with my gas guage???

    Quote Originally Posted by Klink View Post
    IIRC, it is a relatively large multiple ground point, 10 mm bolt head, on a bracket extending down from the left C-pillar. just kind of below and inside from the radio antenna...
    Looked around in there when I had to pull that left trim panel to get all the trunk trim back together right when I first got the car. I will pull the drivers side trunk trim and and check that ground later today. Thanks bro wouldn't have found it without ya!!
    Last edited by Ascension; 07-19-2015 at 06:33 AM.
    "Where justice is denied, where poverty is enforced, where ignorance prevails, and where any one class is made to feel that society is an organized conspiracy to oppress, rob and degrade them, neither persons nor property will be safe." Frederick Douglass

  9. #7

    Re: Weird electrical issue today with my gas guage???

    The Nichrome sensor in the tank likes to get sludged after years and your sensor will do this. Removing the sensor is 5 minutes. Its a aluminum tube with nichrome wiring and a floater inside. on the bottom there is a 7mm nut and it all comes apart. Make sure its all clean and that the nichrome string along with the floater have clean contact.

  10. The Following 2 Users Say Thank You to zibi1988 For This Useful Post:

    Ascension (07-19-2015), gsxr (07-19-2015)

  11. #8
    E420 Guru Ascension's Avatar
    Join Date
    Jul 2014
    Location
    Birmingham Alabama
    Age
    59
    Posts
    914

    Re: Weird electrical issue today with my gas guage???

    Quote Originally Posted by zibi1988 View Post
    The Nichrome sensor in the tank likes to get sludged after years and your sensor will do this. Removing the sensor is 5 minutes. Its a aluminum tube with nichrome wiring and a floater inside. on the bottom there is a 7mm nut and it all comes apart. Make sure its all clean and that the nichrome string along with the floater have clean contact.
    If the ground is not the problem will look at that. My car at some point has had some mild body work in the left rear 1/4 ( one owner car from an elderly couple so---) and maybe they just didn't get the ground tight enough when they put it back together?
    "Where justice is denied, where poverty is enforced, where ignorance prevails, and where any one class is made to feel that society is an organized conspiracy to oppress, rob and degrade them, neither persons nor property will be safe." Frederick Douglass

  12. #9
    E420 Guru Ascension's Avatar
    Join Date
    Jul 2014
    Location
    Birmingham Alabama
    Age
    59
    Posts
    914

    Re: Weird electrical issue today with my gas guage???

    Well got in there today on the ground and maybe I got it. Turns out I had pulled that ground at one point myself while getting after the antenna to lube and clean it and may have not snugged it enough. Went in today and pulled it down another 1/4 turn or so and hopefully that is that. It was a 7mm not a 10mm bolt Heir Klink but you nailed the location so thanks bro!
    "Where justice is denied, where poverty is enforced, where ignorance prevails, and where any one class is made to feel that society is an organized conspiracy to oppress, rob and degrade them, neither persons nor property will be safe." Frederick Douglass

  13. The Following User Says Thank You to Ascension For This Useful Post:

    nocfn (07-19-2015)

Similar Threads

  1. Interior Lighting/Electrical Issue
    By AMGTesTDriverNJ in forum Electrical, CAN and Wiring
    Replies: 5
    Last Post: 05-11-2015, 08:24 AM
  2. Replies: 14
    Last Post: 06-09-2014, 05:49 AM
  3. Potential Electrical Fire Issue
    By DerFuror in forum Electrical, CAN and Wiring
    Replies: 9
    Last Post: 01-29-2013, 09:07 PM
  4. Potential Electrical Fire Issue
    By DerFuror in forum Interior Topics
    Replies: 5
    Last Post: 10-08-2012, 10:01 AM
  5. Air Cond fails sometimes.. Weird!!
    By 993 in forum Heating and Cooling
    Replies: 31
    Last Post: 08-16-2012, 03:30 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •