View Full Version : New 500E Owner with ASR/ABS Light/ Cruise Control failure and weird issue under hard acceleration

12-16-2013, 02:11 PM
I just purchased a 1992 500E out of Tucson AZ. Auto Transport delivered it yesterday. My buddy has had a couple of 500E's over the years and I have been watching.

This one rolled off the truck last night. The ASR light is on and the ABS Light is on. Under hard acceleration the car will just shut down but comes right back when I let off the gas. Under normal driving conditions everything seems to be fine.

I don't have a tool to pull the codes yet. I tried the ebay link from a previous post - but the tool was gone.

Anyone ever had that type of issue under hard acceleration?


12-16-2013, 02:27 PM
Welcome aboard. :welcome3:

Did you get the black/black one here (http://www.500eboard.com/forums/showthread.php?4937-FS-1992-500E-Black-Black-133kmi-12k-(Tucson-AZ)), or the black/cream one here (http://www.500eboard.com/forums/showthread.php?5108-FS-1992-500E-Black-Cream-175kmi-eBay-(Tucson-AZ))? Both were for sale in Tucson recently.

ASR and ABS lights both on sounds like "limp home mode" to me. You can't tell much without the code reader (click here (http://www.ebay.com/itm/221338087939) for a current eBay listing). Toss the paperwork that comes with the code reader, and use the PDF file linked in this post (http://www.500eboard.com/forums/showthread.php?2996-HOW-TO-Checking-DTC-s-(Diagnostic-Trouble-Codes)-on-the-500E-E500) instead.

First things I would check are the date codes on both the upper engine harness, and the ETA. Most common causes of limp mode are a bad ETA or a bad NSS (neutral safety / starter lockout switch). If the ETA is original, it's a prime suspect. Instructions on how to check the date codes for both the harness and ETA are in the forum Wiki:


12-16-2013, 02:39 PM
It was the black/cream one. My buddy Jay Walker has a grey one and previously had a black one. I have a 94 E420 as well that is in excellent condition. The wiring harness was replaced in 2000 by a Mercedes Dealership. The car came with a two inch stack of maintenance history/receipts and the original sales contract.

I just purchased the scanner. Is it OK to drive in LH mode. The E420 is getting seat recovered but I also have a Ford Excursion and a 72 VW Beetle I could drive for the time being.

12-16-2013, 02:40 PM
I'll check the receipts for the ETA.

12-16-2013, 03:03 PM
Welcome to the board! You've come to the right place to enjoy, maintain, and keep your new ride.

12-16-2013, 03:20 PM
Welcome Philip! Good luck with diagnosing your problems. There is some E500E knowledge in Dallas that may be able to help too (I'm thinking of "samiam"). Additionally, Gerry (site guru) will be in Dallas this weekend.

If it comes to swapping out modules in the CAN box, I just picked a bunch up from junkyards and may have one that you can test with.

Just let me (us) know what we can do to help! I am not an expert as I have only had my car for a couple of months. But I am learning!

12-16-2013, 07:32 PM
Thanks Patrick. I'm up the road in Denton. I would like to have lunch/coffee with y'all sometime soon.

12-17-2013, 09:44 AM
I would check that stack of records to see if the throttle actuator has been done. If not, I'd be mighty suspect.


12-17-2013, 10:11 AM
I'm local too=)

There are a bunch of us meeting on Saturday( I think).


12-17-2013, 01:02 PM
Welcome Philip,

I am in Grapevine - but am either traveling - indeed I will be out of town this coming weekend when everyone else in town - or more recently busy being sick :-(

But I am sure the growing Texas "contingent" will all get together sometime in 2014

Hope you get things fixed - as you can see there is plenty of people here willing to help!


12-17-2013, 01:57 PM
Hi and welcome, good luck finding the ABS+ASR issue.
I haven't find mine since months.

12-17-2013, 06:04 PM
Where are the DFW guys meeting on Saturday. I'm free till about 3:00pm.

06-04-2014, 04:57 PM
Was there any results?

Shah Kar
06-05-2014, 05:27 AM

My friend , I had the same problem, some old russian mecanic expert told me to remove the battery pad. I did it and now is ok.


Shah Kar

06-09-2014, 05:49 AM

My friend , I had the same problem, some old russian mecanic expert told me to remove the battery pad. I did it and now is ok.


Shah Kar
what is the battery pad?
Thank alot.