PDA

View Full Version : OWNER - Ascension (E420)



Ascension
07-22-2014, 11:34 PM
Bought this one first week of July as a one owner 95K local new car trade in. Wasn't looking for a car but a long time friend who is a wholesaler got this one in a package deal from a local Honda dealer. The guy normally doesn't deal in anything older than 10 years and euro cars so he hit me with a deal I had to consider. I was going to pass on what I assumed was a clean plain 6 cylinder car until I saw the 420 badge:v8: . When I realized what it was and did finally drive it I was hooked.
Here is what she looked like the first time I took it out.
https://www.500eboard.com/forums/images/imported/2014/07/93.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN0932_zpsded37dfb.jpg.html)
https://www.500eboard.com/forums/images/imported/2014/07/94.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN0933_zpsed7dfd25.jpg.html)
https://www.500eboard.com/forums/images/imported/2014/07/95.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN0935_zpseee52482.jpg.html)
https://www.500eboard.com/forums/images/imported/2014/07/29.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN0936_zps5198fdeb.jpg.html)

Ascension
07-22-2014, 11:44 PM
Now after just over a week I am making progress.
Exterior with a fresh coat of wax and new set of tires.
https://www.500eboard.com/forums/images/imported/2014/07/24.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN0941_zps30c0c346.jpg.html)
Interior after a good scrub down and leather condition.
https://www.500eboard.com/forums/images/imported/2014/07/26.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN0943_zps803fe1f7.jpg.html)
https://www.500eboard.com/forums/images/imported/2014/07/27.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN0944_zpsc9128062.jpg.html)
And under-hood with a decent clean up. I replaced the broken plastic filler cap and got a good bit more done today on the clean and detail under hood. It's bone dry around the cam mags so far and super clean underneath also.
https://www.500eboard.com/forums/images/imported/2014/07/67.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN0954_zps62421c0d.jpg.html)
Needs a trans service next + has a slightly bent a left tie rod and leaking damper but other wise is in great shape. Upper harness seems intact but will be replaced in the future. Dead silent at idle and pulls strong. Looking forward to playing with it a little as time goes by and love owning a real sleeper like this one!

KarlC
07-23-2014, 09:27 AM
Very nice and I'm just that under your care it will just get better. Please keep posting your progress !

Thx for sharing.

gerryvz
07-23-2014, 09:33 AM
You should inspect all of your tie rods and ball joints, idler arm bushings, etc. -- you can get good quality Lemforder aftermarket parts via places like AutohausAZ.com at decent prices, and it's a DIY job to replace the tie rods and such as long as you have a good ball joint popper.

When you get all of the suspension inspected and repaired, then go to the dealer (one of the rare times I'd recommend an MB stealer for anything) and get a "real" MB 4-wheel alignment. It will probably cost you $125-175 to do so, but it is worth it.

clarkz71
07-23-2014, 10:43 AM
I was going to pass on what I assumed was a clean plain 6 cylinder car until I saw the 420 badge:v8: . When I realized what it was and did finally drive it I was hooked.



That's the cool thing about the 400E420

It looks like a 6 banger, but with a 275 hp M119


Replace the 95 LH module in yours with a 92 LH module and you have 290 hp in W124

KarlC
07-23-2014, 10:52 AM
That's the cool thing about the 400E420

It looks like a 6 banger, but with a 275 hp M119


Replace the 95 LH module in yours with a 92 LH module and you have 290 hp in W124

That and the MPG of the 8 is the same as the 6

Ascension
07-23-2014, 12:32 PM
You should inspect all of your tie rods and ball joints, idler arm bushings, etc. -- you can get good quality Lemforder aftermarket parts via places like AutohausAZ.com at decent prices, and it's a DIY job to replace the tie rods and such as long as you have a good ball joint popper.

When you get all of the suspension inspected and repaired, then go to the dealer (one of the rare times I'd recommend an MB stealer for anything) and get a "real" MB 4-wheel alignment. It will probably cost you $125-175 to do so, but it is worth it.

Already did the full inspection and everything looked good but the left tie rod that some bonehead intentionally bent I suspect to try to get the toe set and the leaking damper. My local MB dealer is OUT and I don't EVER want to see that place again ( I think MB US is likely of the same opinion as they have a pending suit with the jerks!! http://www.al.com/business/index.ssf/2013/12/hoovers_crown_automobile_suing.html ) so have to find an independent who can do the alignment right at least till MB US get the other dealership up and running.

gerryvz
07-23-2014, 02:53 PM
Since you're in the Birmingham area, the best indy shop was one we visited and had some tech sessions at last year as part of the MBCA StarTech event. They have a brand-new Hunter alignment machine in the shop and actually demonstrated for the assembled crowd how to do an alignment. Folks like Trae, sheward, jhodg5ck, Jackasic and a few others from the forum were in the crowd.

The name of the shop is Classic Car Motoring, and the address is 102 Black Creek Rd., Birmingham. 35217
Telephone: (205) 841-2153http://www.500eboard.com/forums/image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAA f8/9hAAAACXBIWXMAAA7EAAAOxAGVKw4bAAAKT2lDQ1BQaG90b3No b3AgSUNDIHByb2ZpbGUAAHjanVNnVFPpFj333vRCS4iAlEtvUh UIIFJCi4AUkSYqIQkQSoghodkVUcERRUUEG8igiAOOjoCMFVEs DIoK2AfkIaKOg6OIisr74Xuja9a89 bN/rXXPues852zzwfACAyWSDNRNYAMqUIeEeCDx8TG4eQuQIEKJHA AEAizZCFz/SMBAPh PDwrIsAHvgABeNMLCADATZvAMByH/w/qQplcAYCEAcB0kThLCIAUAEB6jkKmAEBGAYCdmCZTAKAEAGDLY 2LjAFAtAGAnf bTAICd Jl7AQBblCEVAaCRACATZYhEAGg7AKzPVopFAFgwABRmS8Q5ANg tADBJV2ZIALC3AMDOEAuyAAgMADBRiIUpAAR7AGDIIyN4AISZA BRG8lc88SuuEOcqAAB4mbI8uSQ5RYFbCC1xB1dXLh4ozkkXKxQ 2YQJhmkAuwnmZGTKBNA/g88wAAKCRFRHgg/P9eM4Ors7ONo62Dl8t6r8G/yJiYuP 5c rcEAAAOF0ftH LC zGoA7BoBt/qIl7gRoXgugdfeLZrIPQLUAoOnaV/Nw H48PEWhkLnZ2eXk5NhKxEJbYcpXff5nwl/AV/1s X48/Pf14L7iJIEyXYFHBPjgwsz0TKUcz5IJhGLc5o9H/LcL//wd0yLESWK5WCoU41EScY5EmozzMqUiiUKSKcUl0v9k4t8s wM 3zUAsGo AXuRLahdYwP2SycQWHTA4vcAAPK7b8HUKAgDgGiD4c93/ 8//UegJQCAZkmScQAAXkQkLlTKsz/HCAAARKCBKrBBG/TBGCzABhzBBdzBC/xgNoRCJMTCQhBCCmSAHHJgKayCQiiGzbAdKmAv1EAdNMBRaIaT cA4uwlW4Dj1wD/phCJ7BKLyBCQRByAgTYSHaiAFiilgjjggXmYX4IcFIBBKLJCDJ iBRRIkuRNUgxUopUIFVIHfI9cgI5h1xGupE7yAAygvyGvEcxlI GyUT3UDLVDuag3GoRGogvQZHQxmo8WoJvQcrQaPYw2oefQq2gP 2o8 Q8cwwOgYBzPEbDAuxsNCsTgsCZNjy7EirAyrxhqwVqwDu4n1Y8 xdwQSgUXACTYEd0IgYR5BSFhMWE7YSKggHCQ0EdoJNwkDhFHCJ yKTqEu0JroR cQYYjIxh1hILCPWEo8TLxB7iEPENyQSiUMyJ7mQAkmxpFTSEtJ G0m5SI ksqZs0SBojk8naZGuyBzmULCAryIXkneTD5DPkG Qh8lsKnWJAcaT4U IoUspqShnlEOU05QZlmDJBVaOaUt2ooVQRNY9aQq2htlKvUYeo EzR1mjnNgxZJS6WtopXTGmgXaPdpr h0uhHdlR5Ol9BX0svpR iX6AP0dwwNhhWDx4hnKBmbGAcYZxl3GK YTKYZ04sZx1QwNzHrmOeZD5lvVVgqtip8FZHKCpVKlSaVGyovV KmqpqreqgtV81XLVI pXlN9rkZVM1PjqQnUlqtVqp1Q61MbU2epO6iHqmeob1Q/pH5Z/YkGWcNMw09DpFGgsV/jvMYgC2MZs3gsIWsNq4Z1gTXEJrHN2Xx2KruY/R27iz2qqaE5QzNKM1ezUvOUZj8H45hx Jx0TgnnKKeX836K3hTvKeIpG6Y0TLkxZVxrqpaXllirSKtRq0f rvTau7aedpr1Fu1n7gQ5Bx0onXCdHZ4/OBZ3nU9lT3acKpxZNPTr1ri6qa6UbobtEd79up 6Ynr5egJ5Mb6feeb3n hx9L/1U/W36p/VHDFgGswwkBtsMzhg8xTVxbzwdL8fb8VFDXcNAQ6VhlWGX4YSR udE8o9VGjUYPjGnGXOMk423GbcajJgYmISZLTepN7ppSTbmmKa Y7TDtMx83MzaLN1pk1mz0x1zLnm eb15vft2BaeFostqi2uGVJsuRaplnutrxuhVo5WaVYVVpds0at na0l1rutu6cRp7lOk06rntZnw7Dxtsm2qbcZsOXYBtuutm22fW FnYhdnt8Wuw 6TvZN9un2N/T0HDYfZDqsdWh1 c7RyFDpWOt6azpzuP33F9JbpL2dYzxDP2DPjthPLKcRpnVOb00 dnF2e5c4PziIuJS4LLLpc Lpsbxt3IveRKdPVxXeF60vWdm7Obwu2o26/uNu5p7ofcn8w0nymeWTNz0MPIQ BR5dE/C5 VMGvfrH5PQ0 BZ7XnIy9jL5FXrdewt6V3qvdh7xc 9j5yn M 4zw33jLeWV/MN8C3yLfLT8Nvnl F30N/I/9k/3r/0QCngCUBZwOJgUGBWwL7 Hp8Ib OPzrbZfay2e1BjKC5QRVBj4KtguXBrSFoyOyQrSH355jOkc5pD oVQfujW0Adh5mGLw34MJ4WHhVeGP45wiFga0TGXNXfR3ENz30T 6RJZE3ptnMU85ry1KNSo qi5qPNo3ujS6P8YuZlnM1VidWElsSxw5LiquNm5svt/87fOH4p3iC N7F5gvyF1weaHOwvSFpxapLhIsOpZATIhOOJTwQRAqqBaMJfIT dyWOCnnCHcJnIi/RNtGI2ENcKh5O8kgqTXqS7JG8NXkkxTOlLOW5hCepkLxMDUzdm zqeFpp2IG0yPTq9MYOSkZBxQqohTZO2Z pn5mZ2y6xlhbL xW6Lty8elQfJa7OQrAVZLQq2QqboVFoo1yoHsmdlV2a/zYnKOZarnivN7cyzytuQN5zvn//tEsIS4ZK2pYZLVy0dWOa9rGo5sjxxedsK4xUFK4ZWBqw8uIq2K m3VT6vtV5eufr0mek1rgV7ByoLBtQFr6wtVCuWFfevc1 1dT1gvWd 1YfqGnRs FYmKrhTbF5cVf9go3HjlG4dvyr Z3JS0qavEuWTPZtJm6ebeLZ5bDpaql aXDm4N2dq0Dd9WtO319kXbL5fNKNu7g7ZDuaO/PLi8ZafJzs07P1SkVPRU lQ27tLdtWHX G7R7ht7vPY07NXbW7z3/T7JvttVAVVN1WbVZftJ 7P3P66Jqun4lvttXa1ObXHtxwPSA/0HIw6217nU1R3SPVRSj9Yr60cOxx /p3vdy0NNg1VjZzG4iNwRHnk6fcJ3/ceDTradox7rOEH0x92HWcdL2pCmvKaRptTmvtbYlu6T8w 0dbq3nr8R9sfD5w0PFl5SvNUyWna6YLTk2fyz4ydlZ19fi753G DborZ752PO32oPb 6EHTh0kX/i c7vDvOXPK4dPKy2 UTV7hXmq86X23qdOo8/pPTT8e7nLuarrlca7nuer21e2b36RueN87d9L158Rb/1tWeOT3dvfN6b/fF9/XfFt1 cif9zsu72Xcn7q28T7xf9EDtQdlD3YfVP1v 3Njv3H9qwHeg89HcR/cGhYPP/pH1jw9DBY Zj8uGDYbrnjg OTniP3L96fynQ89kzyaeF/6i/suuFxYvfvjV69fO0ZjRoZfyl5O/bXyl/erA6xmv28bCxh6 yXgzMV70VvvtwXfcdx3vo98PT R8IH8o/2j5sfVT0Kf7kxmTk/8EA5jz/GMzLdsAAAAgY0hSTQAAeiUAAICDAAD5/wAAgOkAAHUwAADqYAAAOpgAABdvkl/FRgAAAaNJREFUeNqk009oz3Ecx/HH9/P9/YQRWSi2MGmNrebkpJgSLluKEw5Kk5zUsgMOTrO42MUVxUWRg LgaPWbUGq7rRk7sExKNPt9vx8H32l921z2vrw n3fvz/Pz/vP5JDFGy7HKwk1/fz/sR09VNjAZG6fv1buQHcZm3P8vAMfwCKswncoHCn8nbuAratiEU QglwLXiMJz/FhvWYC9OFb4htBV6B9VyBtsKzRJxbDhvbSS5i1kcQo736MNrjJ cBeaG3MuFyInagA0fwckHcGzzGiXIJU38bk1U x3W x7U/yOvYU4prwG5MlAHPoS4925TMNDeHLxNUh0gGcRC9eFqk34TBMu AhfmL9b5Vz3elIbAmfLq02d4HQhbc4gBYcxUgZMFrcIJecrsga T6avdl6sPqu1hw9XSWs4U5Q6udgYFfP he25MEysVWQvutORLcfTYax4gn3z/VoM8A7Xi/WuKNmQCRujpLc1TGkP46hOI1sKADdxG3PzjkzoTNCT1rSFiX PuLIEoI4rGC 6/xEPMsFKs7YmM8bsAMlyf2OwTPszAMZMeayGCpJVAAAAAElFTkS uQmCC (http://www.500eboard.com/forums/)

http://www.classiccarmotoring.com/

One of the most impressive independent shops I've ever seen.
They are an MB factory-approved paint and restoration shop. Having toured their facility, I absolutely would not hesitate to have them take care of any needed E500E maintenance or repair job.

Cheers,
Gerry

clarkz71
07-23-2014, 03:03 PM
One of the most impressive independent shops I've ever seen.
They are an MB factory-approved paint and restoration shop. Having toured their facility, I absolutely would not hesitate to have them take care of any needed E500E maintenance or repair job.

Cheers,
Gerry

How about 400E420 cars?

:o

gerryvz
07-23-2014, 03:08 PM
How about 400E420 cars?

:oAnd the 90% focus of this site is .....

31312


OK Vader, you get a quarter-yoink....

31313

clarkz71
07-23-2014, 03:19 PM
And the 90% focus of this site is .....


OK Vader, you get a quarter-yoink....

31313

I'll take the 0.5 yoink, and remind you the thread title is................

https://www.500eboard.com/forums/images/imported/2014/07/52.png

gerryvz
07-23-2014, 03:20 PM
Thats a quarter yoink, mind you.


Sent from my iPhone using Tapatalk

clarkz71
07-23-2014, 04:21 PM
I'll remember that when I'm filling positions in my administration...https://www.500eboard.com/forums/images/imported/2014/07/53.png

036
07-23-2014, 04:24 PM
And the 90% focus of this site is .....

31312

You´ve damaged my grill and Jelmer´s ruf... :D:D

gsxr
07-23-2014, 05:48 PM
That and the MPG of the 8 is the same as the 6
I was amazed with the fuel economy when we bought our first E420 as a "trial". Which is why we are on our third one now.

IMO, the 124.034 (especially 93-95 models) are the absolute best bang for the buck of any used 124 in the current market. Fantastic daily drivers.

:v8:

clarkz71
07-23-2014, 05:51 PM
Again, I have to agree with Dave.........:cheers3:

gerryvz
07-23-2014, 07:58 PM
Some serious bro-mance going on between GSXR and Vader.

gsxr
07-23-2014, 08:02 PM
Luke... I am your father!! (Give in to the dark side of the Force, you knob!)

https://www.500eboard.com/forums/images/imported/2014/07/99.jpg

clarkz71
07-24-2014, 03:18 AM
Some serious bro-mance going on between GSXR and Vader.

I feel an anti-034 sentiment in the force.......

Ascension
10-15-2014, 08:14 AM
Been a while since I updated the Owner thread so---.
First off it has been a challenge getting this one back right.
It was a true one owner low mile car but for the last 10 years or so has been serviced by a particular quick oil that really screwed the car up pretty good.
In the couple months I have owned the car it has been a constant process of doing a little something to her almost every day.
Examples are here.
First thing I found was a vacuum line that had been knocked off by the brake booster.
https://www.500eboard.com/forums/images/imported/2014/09/146.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN1075_zps078ecbb0.jpg.html)
REALLY had the car screwed up as it was not shifting properly and overall just was super sluggish.
Next was that the center plugs on both banks were left so loose I was fortunate they didn't blow out and kill the threads in the heads>
https://www.500eboard.com/forums/images/imported/2014/09/188.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN1083_zps057020fb.jpg.html)
https://www.500eboard.com/forums/images/imported/2014/09/187.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN1082_zps5fe9f2b1.jpg.html)
The sludge you see on these plugs is NOT from a valve cover gasket but blow by that had collected in the hole. This stuff was super thick and very very sticky. I used a shotgun cleaning swab to mop up the mess in the tubes and clean the head threads up.
https://www.500eboard.com/forums/images/imported/2014/09/189.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN1084_zps7d86e745.jpg.html)
When I got it the left tie rod was bowed badly we think from the boneheads at the quick oil getting it with a floor jack or a rack. A new left tie rod and proper 4 wheel alignment with a spreader bar cured that issue quickly.
I dodged a bullet when I changed the oil for the 1st time a few days ago as the POS filter was disintegrating. This was the filter that came out with just under 3 K since the last change.
https://www.500eboard.com/forums/images/imported/2014/10/42.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN1120_zps9e27ef3e.jpg.html)
Then there was the PS reservoir that looked like it was full of strong coffee and filed to the very top.
Now has a fresh filter and is running Royal Purple Synthetic. Funny how all the little PS leaks suddenly just stopped after that ain't it?
Trans had never been changed at 95K. Fresh filter and fluid in the pan this time with Castrol DEX MERC and have done one pan drain and fill so far will do another soon then will flush with Seafoam trans Tune right before changing all the fluid including a converter drain and the filter again at the next oil change in 7K and go to Red line or Royal Purple.

The trunk was a mess everything was there but just thrown in and dirty.
Here it is now
https://www.500eboard.com/forums/images/imported/2014/08/219.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN1068_zps29caf0e6.jpg.html)
https://www.500eboard.com/forums/images/imported/2014/08/220.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN1069_zps513f56a7.jpg.html)
https://www.500eboard.com/forums/images/imported/2014/08/221.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN1070_zps150d5caf.jpg.html)
Underhood was just neglected and nasty>
https://www.500eboard.com/forums/images/imported/2014/07/29.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN0936_zps5198fdeb.jpg.html)
But now is in a LOT better shape!
https://www.500eboard.com/forums/images/imported/2014/10/63.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN1080_zps9ade850b.jpg.html)
https://www.500eboard.com/forums/images/imported/2014/07/65.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN0952_zpsa5f51332.jpg.html)
Still have to find a way to get that nasty looking yellowed coating off the heads and block without etching the aluminum but otherwise she is looking pretty decent under the hood now.
More to come!

KarlC
10-15-2014, 08:48 AM
Looking good, nice work !

gerryvz
10-15-2014, 09:15 AM
I feel an anti-034 sentiment in the force.......Yes, the soft bigotry of lower .034 performance :stickpoke:

clarkz71
10-15-2014, 09:34 AM
Yes, the soft bigotry of lower .034 performance :stickpoke:

Could be worse, I could have an even lower performance M104 powered car.


93 400E, 275hp +15 with 92 module = 290hp.....:agree:

94 E320 M104 , 217hp (edited)............:doh:

gerryvz
10-15-2014, 10:06 AM
The M104 as used in the US-spec W124 had 217HP (Euro 221HP); as used in the W463 had 210HP but more torque than the W124 version. (M103 in the US-spec W124 had 177HP).

clarkz71
10-15-2014, 10:22 AM
Wow, I didn't remember the M104 being rated that low.

For some reason I had 245 on my mind......... must be another engine I'm thinking of

No wonder the W140 S320 was such a slug, all that weight and no power.


https://www.500eboard.com/forums/images/imported/2014/10/7.png

8899
10-15-2014, 10:23 AM
Been a while since I updated the Owner thread so---.
First off it has been a challenge getting this one back right.
It was a true one owner low mile car but for the last 10 years or so has been serviced by a particular quick oil that really screwed the car up pretty good.
In the couple months I have owned the car it has been a constant process of doing a little something to her almost every day.


So....what's the verdict? Are 90s era Volvos still better cars?
:stickpoke:

gerryvz
10-15-2014, 10:27 AM
No wonder the W140 S320 was such a slug, all that weight and no power.Not to mention my 5,200+ pound G320. http://www.vpsingles.com/pics/snail.gif

clarkz71
10-15-2014, 10:45 AM
Not to mention my 5,200+ pound G320. https://www.500eboard.com/forums/images/imported/2014/10/1.gif

Never crossed my mind..............:v8:


Oooops, we've high jacked this thread........

Ascension
10-15-2014, 02:23 PM
So....what's the verdict? Are 90s era Volvos still better cars?
:stickpoke:

Apples to oranges.

The E-420 Benz is smoother riding, faster, gets better gas mileage and is overall more fun to drive. However it's VERY spartan and utilitarian inside in comparison to the Volvo and seems somehow less robust and more fragile in overall build quality.
The Volvo on the other hand is much sharper in the handling and is just LIGHT years nicer on the inside in every way than the E Class is and honestly seems to be slightly the more robust better built car overall between the 2. It's also unfortunately underpowered, thirsty, slow and overall feels slightly less refined to drive.
Both are absolutely amazing well built cars that have very different personality's.
the Eco junk wiring issue with the E-420 is the real decider and IMO puts the Volvo well over the top as the better overall car of the 2 all things considered. Without that it's pretty even with just a slight nod to the Volvo for much better interior materials + slightly better fit and finish.That's not looking just at my E-420 but several other Benzes from the same era.
It's not that the E-420 is not good it is it's that this Volvo is just amazing. Many consider these 97-98 S and V 90 Volvos to be the best cars Volvo ever built and I really agree with that as I have flat seen no better build quality than this V-90 on anything else. Nothing I have seen from Volvo before or after has been the equal in overall build quality to the last few years of the 960/90 cars and these are considered by most to be the last of the real Volvos.
Bottom line is I like um both a lot and for now am keeping both.

Ascension
01-15-2015, 07:51 PM
Haven't thrown anything in the owner thread in a while so---.
The wife and I both have finally stabilized in our job situations after a few months of rough times so finally have a little $ to pick up some parts but unfortunately seems every off day it's ether super cold, raining or both and as a result haven't got much done. Right now I'm picking up parts like brakes, throttle cable, thermostat and coolant waiting for the day where the weather is not nasty I'm off and can get to it. Stinks that I don't have a garage here as this sucks to not be able to get things done!! Working 50+ a week right now so just so little time.
Still have a couple things to figure out like the double engagement trans thing only on the initial pull off on cold mornings, and a problem with the intermittent setting on my wipers. Otherwise the car is running like a champ and has turned out to be quite surprisingly good on gas for what it is.

samiam44
01-16-2015, 12:35 PM
Don't even understand this? "double engagement trans thing only on the initial pull off on cold mornings" There is a low speed hold to help heat the CAT.

clarkz71
01-16-2015, 12:44 PM
Don't even understand this? "double engagement trans thing only on the initial pull off on cold mornings" There is a low speed hold to help heat the CAT.

lol, not like it's in the owners manual or anything.......... (It is in there)

And it's very easy to disable with no check engine light. But......... that's classified for some.

gsxr
01-16-2015, 03:29 PM
Don't even understand this? "double engagement trans thing only on the initial pull off on cold mornings"
"Double engagement" when cold is a problem with higher-mile 722.3/.4 transmissions, there is a factory TSB. I have had the problem on a couple of my cars. Usually only one time, when first pulling out of the driveway in the morning.

http://www.w124performance.com/docs/mb/transmission/trans_dbl_engage.pdf

:mushroom:

clarkz71
01-16-2015, 03:44 PM
Only problem is that TSB is from 1995

The fluid back then both standard and the "special" blend are different then what is being sold now.

They had Dexron II back then, now we have Dex/Merc blends.
And since the issue "can be" fluid related per the TSB there's no way
to try the fluid test first.

I would try Jono's idea of "type F" fluid. He said it fix's a myriad of transmission problems

gsxr
01-16-2015, 03:51 PM
To clarify: Double engagement is a real issue and it affects some 722.x automatics. As to what may or may not fix it, I'll let the experts discuss it.

:mushroom:

gerryvz
01-16-2015, 04:14 PM
Only problem is that TSB is from 1995

The fluid back then both standard and the "special" blend are different then what is being sold now.

They had Dexron II back then, now we have Dex/Merc blends.
And since the issue "can be" fluid related per the TSB there's no way
to try the fluid test first.

I would try Jono's idea of "type F" fluid. He said it fix's a myriad of transmission problemsnice ATF trash talk...

.14 spec ATF anyone? :stickpoke:



:pc1::pc1::pc1:

:watchdrama::watchdrama::watchdrama:

:jono: :jono: :jono:

clarkz71
01-16-2015, 04:27 PM
To clarify: Double engagement is a real issue and it affects some 722.x automatics.
As to what may or may not fix it, I'll let the experts discuss it.




Now I'm confused, what will fix it is in the TSB, ...........B2

You posted it, come on Dave........;)


https://www.500eboard.com/forums/images/imported/2015/01/5.png

clarkz71
01-16-2015, 05:58 PM
nice ATF trash talk...

.14 spec ATF anyone? :stickpoke:



That would be ideal, but cost would be a factor........

Getting nippy in South Florida, 62°f right now......brrrrrr

Ascension
01-16-2015, 06:42 PM
"Double engagement" when cold is a problem with higher-mile 722.3/.4 transmissions, there is a factory TSB. I have had the problem on a couple of my cars. Usually only one time, when first pulling out of the driveway in the morning.

http://www.w124performance.com/docs/mb/transmission/trans_dbl_engage.pdf

:mushroom:
Yep exactly my issue in that on a cold morning back down the driveway drop it in drive and it moves then suddenly disengages and reengages just that once, any other time it shifts and works perfectly. It surfaced right after I changed the fluid and filter and went to the Castrol Dex Mercon. I'm thinking a change to Redline D4 might do the trick.

Ascension
08-08-2015, 07:47 AM
Been a while since I updated the owners thread here. Had a serious family situation with health of my mother that had us running over to another city on every off day for A few months so almost nothing got done to the 420 for quite a while.
Got back on track with the car just over a month ago.
Got frustrated with the nasty looking yellow coating on the valve covers and spent a while hand scraping it off with a single edge razor blade.
Before
https://www.500eboard.com/forums/images/imported/2014/10/63.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN1080_zps9ade850b.jpg.html)
After
https://www.500eboard.com/forums/images/imported/2015/03/185.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN1253_zpsjky1y9lz.jpg.html)
https://www.500eboard.com/forums/images/imported/2015/03/188.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN1256_zps0gtllodc.jpg.html)
Did the upper harness
https://www.500eboard.com/forums/images/imported/2015/04/126.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN1289_zpsxiyfubwk.jpg.html)
https://www.500eboard.com/forums/images/imported/2015/04/123.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN1294_zpslnvqgevo.jpg.html)
Old was so toasted can't understand how the car even ran!!
https://www.500eboard.com/forums/images/imported/2015/04/120.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN1296_zpsz5jfdkri.jpg.html)
Also did caps rotors and insulators.
As of this week dropped a new set of 17/7.5 ANZIOS and 215/50/17 V rate P7's on the car + stripped off those stupid tape pinstripes.
From this look

https://www.500eboard.com/forums/images/imported/2014/11/154.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN1085_zps4b2b3dcb.jpg.html)
to THIS and suddenly she no longer looks like a grandma's grocery getter!
https://www.500eboard.com/forums/images/imported/2015/08/55.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN1349_zpsuycrt2lc.jpg.html)
The difference in ride quality and handling was simply remarkable. It's so much smoother riding and feels like a completely different car on the road!!
Next up will be grabbing an AMG kit and spacing the front fenders as I have very slight rubbing then tint before doing the lower harness and motor mounts.

Ascension
08-13-2015, 06:58 AM
Some more photos of the car with teh new wheel tire set up showing the stance from a distance.
https://www.500eboard.com/forums/images/imported/2015/08/96.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN1366_zpsy0sqw4gy.jpg.html)
https://www.500eboard.com/forums/images/imported/2015/08/93.jpg (http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN1369_zpsd5kew0gf.jpg.html)
Plan on painting the inside of the grill the same gray as the wheels ( leaving the chrome just the inside dark area), tinting the windows and maybe pulling the gun-sight.

luckymike
08-13-2015, 09:19 AM
Wanted to make a joke about how removing your pinstripe made a remarkable difference in your ride quality and handling but couldn't make it work. It's the thought that counts!

I pulled my 'gun-sight' and replaced with the flat emblem. I think it's more fitting to the car.

Ascension
10-15-2015, 12:42 AM
In the end had to bump back to the 215/45/17 P7's from the 215/50/17's as we had pretty good rubbing issues and weird bump steer issue at speed couldn't get out as well as the speedo was off.
The new 215/45/17's are dead on the height of the stockers so all the rubbing issues the speedo error and the weird bump steer issue at speed just vanished with the new set and now all is well.
Here is a photo now of the stance.
IMO it really changed the personality of this car pulling those nasty stripes and dropping this wheel tire combo on. Only thing is many who see it from the rear or a side at a distance think it's a BMW not a Merc at first because they are not used to seeing one of these cars with non stock wheels and this aggressive a stance.

https://www.500eboard.com/forums/images/imported/2015/08/128.jpg
(http://smg.photobucket.com/user/rutledri/media/1995%20E-420/DSCN1372_zpsmog0kopj.jpg.html)
Have a 92 WOT full enrich ready to go in when I get the motor mounts done but right now she is a DD back and forth to work and running like a champ.
Couple weeks back caught a guy with a sharp kinda metallic burnt orange 3 series BMW who had stopped on the end of the ramp between I-20 and I-459 coming home from work. Slowed down to round 35 or so as I rolled up when he suddenly launched and turning it up. Just couldn't pass up a chance to play had a roll on him and it must have freaked him out badly when the ol 034 responded then reeled him in quickly and nearly ran up his bumper. When we got to the open 6 lane right as I caught him I just stepped over and blitzed by like he was tied to a stump then let off around 115 or so. Had the weirdest look of disbelief and confusion when he pulled up and took a look at that innocent looking old Green E-class that had just slammed his doors so badly LOL.
Really digging this car and now lusting after a 500.

Ascension
09-21-2016, 09:48 PM
Been a while since I have had time to do much more than lurk around here due to work and family. Between a terminally ill boss and a mother in and out of the hospital all summer every off day has been spent on the road ( when I got one) so slow progress on the 420.
Did not quit and give up on the 420 and so far since my last post have a new ETA ( thanks Jeff!!) in and motor mounts installed +. My thanks to Phillip here at World Class Auto in Birmingham and our own heir Klink for assistance would have been a lost cause with out both you guys.
Still need at some point to replace the lower harness but the car is now running well.

gsxr
09-22-2016, 08:33 AM
Been wondering where you went! Do you already have a new lower harness? If not, that may be a problem... they are NLA now.

:runexe:

Ascension
09-22-2016, 07:18 PM
Been wondering where you went! Do you already have a new lower harness? If not, that may be a problem... they are NLA now.

:runexe:

Thought that harness was a safe bet on availability seeing how all these self destruct if not updated.
No I don't and yep found out about the NLA or would have done one.

nocfn
09-22-2016, 07:20 PM
Ref the e420 or the E500?

Ascension
09-22-2016, 07:37 PM
Ref the e420 or the E500?
420 was told it was NLA last week.