Results 1 to 10 of 10

Thread: ASR light

  1. #1
    Member aldedmon's Avatar
    Join Date
    Mar 2011
    Location
    Houston,TX
    Posts
    62

    ASR light

    Iím trying to narrow down the issue with my ASR light coming on. Iíve done most of the usual checks and was hoping someone with technical expertise could solve my issue. Iíve discovered that the light comes on exactly 2:58 seconds after I start the car. I can just start it first thing in the morning or restart it at anytime . I can drive it or it be sitting still. Like clock work the light comes on in 2:58 secs. Any ideas? By the way the car still seems to have full function. It only rarely goes into limp home mode but thatís after the ASR light has been in for a while...
    Regards,

    Albert
    aldedmon@yahoo.com

  2. The Following User Says Thank You to aldedmon For This Useful Post:

    TerryA (05-17-2018)

  3. #2
    .036 Hooniganô
    E500E Boffin
    gsxr's Avatar
    Join Date
    Dec 2008
    Location
    Boise, ID, USA
    Posts
    21,144

    Re: ASR light

    What codes appear on the E-GAS and ASR modules? Do you have spares of either module that you can swap in for testing?


  4. The Following User Says Thank You to gsxr For This Useful Post:

    TerryA (05-17-2018)

  5. #3
    Member aldedmon's Avatar
    Join Date
    Mar 2011
    Location
    Houston,TX
    Posts
    62

    Re: ASR light

    Have constructed a decoder (ring) . No spares either . Iím On the look out for reasonably priced ones that I can swapped to check


    Sent from my iPhone using Tapatalk

  6. The Following User Says Thank You to aldedmon For This Useful Post:

    TerryA (05-17-2018)

  7. #4
    Member aldedmon's Avatar
    Join Date
    Mar 2011
    Location
    Houston,TX
    Posts
    62

    Re: ASR light

    Also, no CEL noted


    Sent from my iPhone using Tapatalk

  8. #5
    .036 Hooniganô
    E500E Boffin
    gsxr's Avatar
    Join Date
    Dec 2008
    Location
    Boise, ID, USA
    Posts
    21,144

    Re: ASR light

    Pick up a spare E-GAS and ASR module from a 400E / E420 with ASR. These are usually available at a reasonable price via eBay. The ASR module part number will be identical; the E-GAS will not be identical but it will work fine.

    No CEL is expected; the CEL only shows emissions related faults (USA-only thing). CEL doesn't care if there is limp mode or not.


  9. The Following User Says Thank You to gsxr For This Useful Post:

    TerryA (05-17-2018)

  10. #6
    Site Honcho
    Klugscheisser
    Ich bekenne mich
    nicht schuldig.
    gerryvz's Avatar
    Join Date
    Nov 2008
    Location
    Annapolis, MD
    Posts
    17,598

    Re: ASR light

    I just listed appropriate ASR and E-GAS modules for sale last night, here on the forum, that are applicable to the E500E. I'll be happy to make you a deal on both together, and you save a bit of shipping cost as well.

    Cheers,
    Gerry

  11. The Following User Says Thank You to gerryvz For This Useful Post:

    TerryA (05-17-2018)

  12. #7
    Member
    Join Date
    May 2014
    Location
    Finland
    Posts
    79

    Re: ASR light

    Does the ASR pressure pump run when starting engine and stops simultaneusly ASR light on?

    https://www.500eboard.com/forums/sho...064#post145064

  13. The Following 3 Users Say Thank You to Efraim For This Useful Post:

    gsxr (05-15-2018), Klink (05-15-2018), TerryA (05-17-2018)

  14. #8
    postwhore posterchild Klink's Avatar
    Join Date
    Feb 2014
    Location
    Abstract Plains, USA
    Posts
    4,002

    Re: ASR light

    That is probably due to the high-pressure pump being unable to pressurize the pressure reservoir. THAT condition is usually caused by an in operative primer pump. The primer pump is located below the master cylinder. They get stuck due to corrosion formation in the pump wheels, and/or simple lack of use. If you never drive the car aggressively, the pressure reservoir never get to drain down enough to require a recharge, then the day it does, or the day you change brake fluid and open the bleeder “SP” the system is unable to replenish itself. Sometimes, you can start the car reach down there with an appropriately shaped piece of wood, etc. and just smack the thing a few times and it may start to run.
    If not, you can disassemble the pump end of it easily, remove any accumulated corrosion gently, make sure the wheels turn easily, and you are probably good to go. I’ve had excellent luck getting many of them to run again.
    Putting the fun in dysfunction...

  15. The Following 5 Users Say Thank You to Klink For This Useful Post:

    Efraim (05-17-2018), emerydc8 (05-15-2018), gsxr (05-15-2018), nocfn (05-15-2018), TerryA (05-17-2018)

  16. #9
    E500E Guru emerydc8's Avatar
    Join Date
    May 2011
    Location
    Tucson, AZ
    Age
    53
    Posts
    1,311

    Re: ASR light

    Quote Originally Posted by aldedmon View Post
    I’m trying to narrow down the issue with my ASR light coming on. I’ve done most of the usual checks and was hoping someone with technical expertise could solve my issue. I’ve discovered that the light comes on exactly 2:58 seconds after I start the car. I can just start it first thing in the morning or restart it at anytime . I can drive it or it be sitting still. Like clock work the light comes on in 2:58 secs. Any ideas? By the way the car still seems to have full function. It only rarely goes into limp home mode but that’s after the ASR light has been in for a while...
    Had the exact thing happen to me. You could hear the pump stop a few minutes after starting the car, like clockwork, and the ASR light would illuminate. Over a period of a few years, the pump completely stopped running and now causes the ASR light to illuminate constantly. I pulled the bulb out and looked at it as my own auto-antislip-delete feature. I might take Klink's advice and tear into it someday but it's pretty low on my to-do list.
    Jon D.
    1994 E420
    1995 E420

  17. The Following 2 Users Say Thank You to emerydc8 For This Useful Post:

    gsxr (05-15-2018), TerryA (05-17-2018)

  18. #10
    postwhore posterchild Klink's Avatar
    Join Date
    Feb 2014
    Location
    Abstract Plains, USA
    Posts
    4,002

    Re: ASR light

    Quote Originally Posted by emerydc8 View Post
    Had the exact thing happen to me. You could hear the pump stop a few minutes after starting the car, like clockwork, and the ASR light would illuminate. Over a period of a few years, the pump completely stopped running and now causes the ASR light to illuminate constantly. I pulled the bulb out and looked at it as my own auto-antislip-delete feature. I might take Klink's advice and tear into it someday but it's pretty low on my to-do list.
    If you overworked and killed the HP pump, you may have killed your ABS too...
    Putting the fun in dysfunction...

  19. The Following 2 Users Say Thank You to Klink For This Useful Post:

    gsxr (05-17-2018), TerryA (05-17-2018)

Similar Threads

  1. Cluster Light on; the one left of the check engine light
    By Stevester 500E in forum Off-Topic Discussions
    Replies: 3
    Last Post: 03-14-2017, 12:04 PM
  2. '93 400E: Brake Pad Lining Light and Oil Light Flickering
    By FalconOps in forum 400E / E420 Discussions
    Replies: 5
    Last Post: 09-22-2016, 08:32 AM
  3. What causes this light
    By kre8tive202 in forum M119 Engine
    Replies: 15
    Last Post: 11-02-2015, 04:34 PM
  4. SRS light is on
    By Jim Rosenthal in forum Electrical, CAN and Wiring
    Replies: 7
    Last Post: 12-10-2013, 09:57 AM
  5. light out dash light
    By samiam44 in forum Troubleshooting and Diagnostics
    Replies: 2
    Last Post: 02-05-2013, 07:21 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •