Results 1 to 10 of 10

Thread: Fuel Pumps Loud after long drive

  1. #1
    Senior Member
    Join Date
    Apr 2015
    Location
    South East London
    Posts
    214

    Fuel Pumps Loud after long drive

    Hi Guys,

    I have been experiencing a problem with my 500E, after a long drive and a hot day, if I turn the car off and on again, the fuel pumps sound very loud.

    Is this normal behavior?

    I have tried to capture it in the video here: https://www.youtube.com/watch?v=03RlXWDPShY

    Thanks,
    Matin

    Matin

    1992 500E - JAPAN SPEC

  2. #2
    .036 Hoonigan™
    E500E Boffin
    gsxr's Avatar
    Join Date
    Dec 2008
    Location
    Boise, ID, USA
    Posts
    21,325

    Re: Fuel Pumps Loud after long drive

    The pumps should not be louder when hot vs cold. How old are the pumps?

    Dave M.
    1997 E420 (Bugeyes)
    1994 E420 (Blondie)
    1994 E500 (Q-ship)
    1992 500E (Mach 5)
    1987 300D (Sportline Stage 2)
    Click here for my website
    Click here for my YouTube channel

  3. #3
    Senior Member
    Join Date
    Apr 2015
    Location
    South East London
    Posts
    214

    Re: Fuel Pumps Loud after long drive

    I changed them last week.

    theyre brand new!
    Matin

    1992 500E - JAPAN SPEC

  4. #4
    .036 Hoonigan™
    E500E Boffin
    gsxr's Avatar
    Join Date
    Dec 2008
    Location
    Boise, ID, USA
    Posts
    21,325

    Re: Fuel Pumps Loud after long drive

    Yikes. Are you certain they are Genuine Bosch and not counterfeits...?


  5. #5
    Senior Member
    Join Date
    Apr 2015
    Location
    South East London
    Posts
    214

    Re: Fuel Pumps Loud after long drive

    yeah, thing is that my old pumps were making exactly the same noise, so I decided to change them, but the new ones are also making the same noise, so I'm not really sure what's up?

    I've tried two different LH modules and they both the same, not sure what else it could be?

    It sounds asif the fuel pumps are almost dying or something..
    Matin

    1992 500E - JAPAN SPEC

  6. #6
    .036 Hoonigan™
    E500E Boffin
    gsxr's Avatar
    Join Date
    Dec 2008
    Location
    Boise, ID, USA
    Posts
    21,325

    Re: Fuel Pumps Loud after long drive

    Total wild guessing... but maybe the inlet screen from the tank is restricted and the pumps are struggling to pull fuel? I assume the fuel pressure is normal and the car drives OK?

    The LH just triggers a relay to turn the pumps on or off, so if the pumps are running when they are supposed to, the LH wouldn't cause any other issues.


  7. The Following User Says Thank You to gsxr For This Useful Post:

    JC220 (05-21-2018)

  8. #7

    Re: Fuel Pumps Loud after long drive

    We have found that the ground signal from the LH unit when the capacitors are failing will make the fuel pumps noisy by clattering the fuel pump relay and therefor power to the pumps lift the rear seat and find the fuel pump relay pass side and see if it is buzzing when the car is running if so have the Caps changed in the LH control unit

    Or you can with the relay to get ground by rewiring a secondary relay that will connect to ground with any key on hot only draw back is the pump will run as long as the key is on
    we use this method as work around until we can get the customer to release the car long enough time to send the LH out for repair

    Scott
    Long Beach Autohaus

  9. The Following 4 Users Say Thank You to vararacer02 For This Useful Post:

    gsxr (08-02-2018), Hakie (08-02-2018), Klink (08-02-2018), sheward (08-02-2018)

  10. #8
    postwhore posterchild Klink's Avatar
    Join Date
    Feb 2014
    Location
    Abstract Plains, USA
    Posts
    4,035

    Re: Fuel Pumps Loud after long drive

    Does that noise continue, or does it only last for a short period of time after a hot restart?

    Sometimes new pumps start out A LITTLE noisy, but get quieter as they break in. If you feel the relay under the right rear seat buzzing or ratcheting upon a hot restart, repair the LH unit as in the following thread:

    https://www.500eboard.com/forums/showthread.php?t=4554

    Read it all if you want, but you can just start at post 12 if you want to.
    Putting the fun in dysfunction...

  11. The Following 3 Users Say Thank You to Klink For This Useful Post:

    gsxr (08-03-2018), Hakie (08-02-2018), Rouven036 (08-03-2018)

  12. #9
    Senior Member
    Join Date
    Apr 2015
    Location
    South East London
    Posts
    214

    Re: Fuel Pumps Loud after long drive

    Thanks guys.

    the sound kind of died off and I don’t hear it near as much loud as it was before so I assume it was breaking in. I tried two different LH modules and the sound was still the same. But all seems good now.

    thanks
    Matin

    1992 500E - JAPAN SPEC

  13. #10
    Senior Member Eno's Avatar
    Join Date
    Oct 2015
    Location
    Doha, Qatar
    Posts
    317

    Re: Fuel Pumps Loud after long drive

    Also to add, make sure you have the correct fuel pump relay under the passenger rear seat, the correct fuse is the green color with a fuse.
    Not the silver color with a blue cap on without fuse.


    Sent from my iPhone using Tapatalk Pro

Similar Threads

  1. What controls my ETA and Fuel pumps
    By kre8tive202 in forum M119 Engine
    Replies: 11
    Last Post: 01-16-2018, 12:30 AM
  2. Info on new Bosch fuel pumps for E500E
    By gerryvz in forum M119 Engine
    Replies: 40
    Last Post: 11-26-2017, 05:03 AM
  3. Switched from double fuel pumps to single fuel pump
    By Christian_K in forum M119 Engine
    Replies: 58
    Last Post: 11-01-2017, 12:55 PM
  4. Caps/rotors? Catalytic converters? Fuel pumps?
    By mb280sel1985 in forum Troubleshooting and Diagnostics
    Replies: 2
    Last Post: 01-18-2014, 02:55 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •