Results 1 to 5 of 5

Thread: Help needed with ASR Light and Limp Mode

  1. #1
    Junior Member Modpryor's Avatar
    Join Date
    Jan 2013
    Location
    Florida
    Posts
    21

    Help needed with ASR Light and Limp Mode

    When I start my car the ASR light comes on
    and the car is in limp mode & I have to really
    push the accelerator down to get the car going. What do you think is causing this problem please help.

    Thanks


    Sent from my iPhone using Tapatalk

  2. #2
    Senior Member Eno's Avatar
    Join Date
    Oct 2015
    Location
    Doha, Qatar
    Posts
    346

    Re: ASR Light

    There are a few areas to start with:

    1. Check the condition of the transmission Neutral Safety Switch and replace as preventative maintenance, also the rubber bushings.
    2. Check the accelerator control sensor behind the gas pedal.
    3. Get the fault codes from computer test
    4. Check the ASR module ny removing it and place it back firmly in the CAN box.




    Sent from my iPhone using Tapatalk Pro

  3. The Following 2 Users Say Thank You to Eno For This Useful Post:

    Hakie (08-24-2018), Modpryor (08-28-2018)

  4. #3
    Site Honcho
    Klugscheisser
    Ich bekenne mich
    nicht schuldig.
    gerryvz's Avatar
    Join Date
    Nov 2008
    Location
    Annapolis, MD
    Posts
    18,115

    Re: Help needed with ASR Light and Limp Mode

    Any update on this? Did you solve the ASR light and LHM problem?

  5. The Following User Says Thank You to gerryvz For This Useful Post:

    Hakie (11-21-2018)

  6. #4
    Junior Member Modpryor's Avatar
    Join Date
    Jan 2013
    Location
    Florida
    Posts
    21

    Re: Help needed with ASR Light and Limp Mode

    I was told it was because of the throttle body
    wasn’t working properly.

    Thanks


    Sent from my iPhone using Tapatalk

  7. #5
    Site Honcho
    Klugscheisser
    Ich bekenne mich
    nicht schuldig.
    gerryvz's Avatar
    Join Date
    Nov 2008
    Location
    Annapolis, MD
    Posts
    18,115

    Re: Help needed with ASR Light and Limp Mode

    So you replaced the ETA and it solved the problem?

  8. The Following User Says Thank You to gerryvz For This Useful Post:

    Hakie (11-21-2018)

Similar Threads

  1. ASR light and Limp Home mode
    By Edwardsgw in forum Troubleshooting and Diagnostics
    Replies: 5
    Last Post: 08-05-2017, 01:44 PM
  2. Limp Home Mode
    By bryanjchen in forum Troubleshooting and Diagnostics
    Replies: 9
    Last Post: 09-09-2016, 11:54 AM
  3. ASR Light and Limp-Home Mode
    By midnightlsc in forum Troubleshooting and Diagnostics
    Replies: 38
    Last Post: 02-10-2015, 07:12 AM
  4. Limp Mode after revving..?
    By Benzer in forum M119 Engine
    Replies: 3
    Last Post: 05-21-2011, 09:39 PM
  5. Limp mode again
    By 500ESpain in forum Troubleshooting and Diagnostics
    Replies: 20
    Last Post: 04-09-2011, 06:32 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •