Results 1 to 2 of 2

Thread: Help needed with ASR Light and Limp Mode

  1. #1
    Junior Member
    Join Date
    Jan 2013
    Posts
    19

    Help needed with ASR Light and Limp Mode

    When I start my car the ASR light comes on
    and the car is in limp mode & I have to really
    push the accelerator down to get the car going. What do you think is causing this problem please help.

    Thanks


    Sent from my iPhone using Tapatalk

  2. #2
    Senior Member Eno's Avatar
    Join Date
    Oct 2015
    Location
    Doha, Qatar
    Posts
    313

    Re: ASR Light

    There are a few areas to start with:

    1. Check the condition of the transmission Neutral Safety Switch and replace as preventative maintenance, also the rubber bushings.
    2. Check the accelerator control sensor behind the gas pedal.
    3. Get the fault codes from computer test
    4. Check the ASR module ny removing it and place it back firmly in the CAN box.




    Sent from my iPhone using Tapatalk Pro

  3. The Following 2 Users Say Thank You to Eno For This Useful Post:

    Hakie (4 Weeks Ago), Modpryor (3 Weeks Ago)

Similar Threads

  1. ASR light and Limp Home mode
    By Edwardsgw in forum Troubleshooting and Diagnostics
    Replies: 5
    Last Post: 08-05-2017, 12:44 PM
  2. Limp Home Mode
    By bryanjchen in forum Troubleshooting and Diagnostics
    Replies: 9
    Last Post: 09-09-2016, 10:54 AM
  3. ASR Light and Limp-Home Mode
    By midnightlsc in forum Troubleshooting and Diagnostics
    Replies: 38
    Last Post: 02-10-2015, 06:12 AM
  4. Limp Mode after revving..?
    By Benzer in forum M119 Engine
    Replies: 3
    Last Post: 05-21-2011, 08:39 PM
  5. Limp mode again
    By 500ESpain in forum Troubleshooting and Diagnostics
    Replies: 20
    Last Post: 04-09-2011, 05:32 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •