Results 1 to 8 of 8

Thread: MAF Sensor Troubleshooting

  1. #1
    Junior Member
    Join Date
    Mar 2018
    Posts
    6

    MAF Sensor Troubleshooting

    I am pretty sure my MAF sensor is bad, Before I replace it I am trying to check my wiring to MAF and voltage to and fro the MAF. One thing stands out, My burnoff is always hot as in my wire is glowing all the time. My question is how does pin 3 in the MAF sensor get it's charge? Does the signal come from the LH Module or is it hot all the time and switches on and off from the sensor? Just for reference my wiring harness both upper and lower has been replaced with new.

  2. The Following User Says Thank You to markob For This Useful Post:

    TerryA (2 Weeks Ago)

  3. #2
    E500E Guru JC220's Avatar
    Join Date
    Feb 2016
    Location
    Ireland
    Posts
    1,806

    Re: MAF Sensor Troubleshooting

    The link below is for a 1992 500E engine schematic:

    http://www.autolib.diakom.ru/CAR/Mercedes-Benz/1992/500E/SYSTEM%20WIRING%20DIAGRAMS/4340.pdf

    RE MAF testing please refer to this thread post #67 and #69

    The image attached describes the function of the 500E MAF sensor

    500e maf.jpg 500e maf 2.jpg
    Last edited by JC220; 2 Weeks Ago at 01:42 PM. Reason: Edits to add images
    1987 w124 200 - 3.6 AMG build | 1990 w124 300E-24 | 1992 w124 500E

    1994 320CE Sportline | 1997 w140 S280 | 2007 w211 E220CDI

  4. The Following 7 Users Say Thank You to JC220 For This Useful Post:

    195910 (2 Weeks Ago), Christian_K (2 Weeks Ago), Eno (2 Weeks Ago), gsxr (2 Weeks Ago), Jlaa (2 Weeks Ago), Klink (2 Weeks Ago), sheward (2 Weeks Ago)

  5. #3
    Intl 500E GTG coordinator 195910's Avatar
    Join Date
    Dec 2008
    Posts
    1,667

    Re: MAF Sensor Troubleshooting

    The MAF burn-off function is controlled by the LH unit. There are 5 pins (Ground, 12V, signal to LH, Burn-off from LH).
    Is it constantly on? warm up or once warm ?

  6. The Following User Says Thank You to 195910 For This Useful Post:

    gsxr (2 Weeks Ago)

  7. #4
    Intl 500E GTG coordinator 195910's Avatar
    Join Date
    Dec 2008
    Posts
    1,667

    Re: MAF Sensor Troubleshooting

    Question: is Rk the Intake air temperature sensor ? or a sensor in the MAF ?

  8. #5
    postwhore posterchild Klink's Avatar
    Join Date
    Feb 2014
    Location
    Abstract Plains, USA
    Posts
    4,043

    Re: MAF Sensor Troubleshooting

    Quote Originally Posted by 195910 View Post
    Question: is Rk the Intake air temperature sensor ? or a sensor in the MAF ?
    Inside the MAF.
    Putting the fun in dysfunction...

  9. The Following 3 Users Say Thank You to Klink For This Useful Post:

    195910 (2 Weeks Ago), gsxr (2 Weeks Ago), JC220 (2 Weeks Ago)

  10. #6
    Junior Member
    Join Date
    Mar 2018
    Posts
    6

    Re: MAF Sensor Troubleshooting

    Yes it is constantly glowing red and the car runs like crap, If I disconnect it will smooth out and run well again

  11. #7
    .036 Hoonigan™
    E500E Boffin
    gsxr's Avatar
    Join Date
    Dec 2008
    Location
    Boise, ID, USA
    Posts
    21,333

    Re: MAF Sensor Troubleshooting

    Do you have another LH module to use as a test? Any LH module for M119 will work for a quick test, you're looking to see if the MAF stops glowing red all the time with the spare module.


  12. The Following User Says Thank You to gsxr For This Useful Post:

    JC220 (2 Weeks Ago)

  13. #8
    Junior Member
    Join Date
    Mar 2018
    Posts
    6

    Re: MAF Sensor Troubleshooting

    Quote Originally Posted by gsxr View Post
    Do you have another LH module to use as a test? Any LH module for M119 will work for a quick test, you're looking to see if the MAF stops glowing red all the time with the spare module.

    I will attempt purchase one on EBAY today and test.

Similar Threads

  1. Electrical gremlin troubleshooting
    By frm1484 in forum Electrical, CAN and Wiring
    Replies: 0
    Last Post: 03-23-2016, 09:41 AM
  2. Troubleshooting Fuel Odor
    By s4cruiser in forum M119 Engine
    Replies: 13
    Last Post: 01-30-2015, 09:50 AM
  3. Coolant level sensor and Temp sensor [pics]
    By bgalakazam in forum M119 Engine
    Replies: 8
    Last Post: 09-27-2013, 11:33 AM
  4. Help troubleshooting ASR/ABS system
    By Glen in forum Electrical, CAN and Wiring
    Replies: 43
    Last Post: 05-28-2013, 01:39 PM
  5. Replies: 0
    Last Post: 02-13-2013, 02:39 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •