Results 1 to 2 of 2

Thread: Help - Fixed Antenna Replacement Solution / Advice

  1. #1
    Senior Member
    Join Date
    Nov 2010
    Location
    Charlotte, NC
    Posts
    250

    Help - Fixed Antenna Replacement Solution / Advice

    So i have been beating my brains in for literally months trying to wrestle this annoying issue to ground and have thrown in the towel on trying to figure it out on my own and need to consult the wisemen around this forum to help me with part numbers / interchangeability / advice to get me the rest of the way there on the path i have or advise me to take a different path of least resistance solution (apologies in advance for the long post).

    So I have a 92 eurospec that spent a considerable portion of 2017 and 2018 down in ATL with Jono getting what amounted to basically a restoration by the time all was said and done, and when the car left charlotte on the truck it had a fixed mast antenna on it. It appears the carrier was trying to be diligent and do me a favor by unscrewing it so that it wouldn't potentially get knocked off in transit and problem is it also appears he must have misplaced it or forgot to put it back on when he delivered it to Jono and this was all realized when i picked the car up about 10 months later so needless to say there was no potential to track back down its whereabouts via the broker that i used to transport it.

    So with crappy radio reception on most stations and a goofy looking back of my car with just a base "nub" with a screw thread in the top of it, Jono helped me figure out the part number i should be after for the factory fixed mast replacement on Euro models. Not easy to track down in the states, but I finally found a place in the states that could source it (mercedesbenzpastscenter.com) and after a special order to germany, about 3 weeks, and an egregious amount of money for a passive simple metal stick, I had the antenna in hand and went to go screw it in and was super bummed to realize it didnt fit. (I was fortunate that they were great to deal with about the return). So after some digging i realized that my antenna base was from a company called Kathrein and seemed to be different than the original factory stuff, so then I set about digging around with kathrein part numbers and found a promising lead on ebay for old stock antennas of some guy that all appeared visually like they might fit the bill (all cheap at like $10 bucks each) but when none of those worked I soured on that wild goose chase and switched to basically looking to replicate what another forum member did here (post #11 of this post https://www.500eboard.com/forums/showthread.php?t=8804). I have the SLK antenna and the antenna base in my possession now and am trying to finish this pathway but am running into the 2 main below issues that i need help with:

    Problem 1: How to get the shorty antenna base to connect with the Booster / Amplifier:

    - My car has a Kathrein "booster/amplifier" and the end of the my "shorty SLK" antenna base does not match up to fitting this, mine looks like Pic "Kathrein Base"
    - Per the original post it looks like the factory Hirschmann AP 9016/11 works (which i can easily find on eBay) but when i look at the end of the connector to my shorty base (Pics Shorty Base Connections 1-3) and compare it with the threaded position on the AP 9016/11 (AP 9016/11 pic), it doesnt look like a fit to me and if there is a way to make it fit it looks like there is some other connector i may be missing with what i have in my possession at the moment to have it work properly
    - Finally if there is some magic way to get the connection to the Hirschmann AP 9016/11 to work i noticed it has a "12V" input on the device, do i need to somehow run power to that device or is that only for when they connect to an auto antenna?

    Problem 2: What gasket to use between the outer and inner part of the Antenna Base
    - the one in my existing Kathrein base seems to be specific to that item and doesnt fit my new Shorty base
    - I have seen this one (https://www.autohausaz.com/pn/175839...oaAmqsEALw_wcB) which i dont think would work as my "outer" antenna base is not hollow and wouldnt allow the rubber to go up through it. I also found the attached pic on GSXRs website which looks like the right shape and i dont care if i have to by a $75 kit to get a 3 cents piece of rubber at this point but want to stop shooting from the hip with things that i am ordering and just guessing at a fit

    Any guidance here is much appreciated, i have considered the idea of just trying to retrofit in the factory US-Spec, Hirschmann power antenna but prefer to stay fixed mast if possible and going power route seems like a frustrating can of worms as well with having to run power to it and then running something to either que off the radio on/off or creating some form of in cabin switch (on my old w123 there was a dash switch mounted factory switch for antenna up/down, which im guessing US models have but i have no such switch in mine so would need to mount something custom in a discreet location i think)

    as you can see, am fed up with something that i thought was going to be as simple as screwing in a light bulb 4 months ago - thanks in advance for any help
    Attached Images Attached Images

  2. #2
    Senior Member
    Join Date
    Nov 2010
    Location
    Charlotte, NC
    Posts
    250

    Re: Help - Fixed Antenna Replacement Solution / Advice

    Adding on here, seems like I may also be able to just buy the matching slk antenna booster (https://www.ebay.com/itm/2008-2011-M...M/302796149336 ) that I know should fit, just introduces the question of confirming the wire to the radio would fit input and then it looks like this device still needs power in some way shape or form (would assume all antenna amplifiers need some source of power right?)....I am less familiar in the electronics realm so not sure where I can draw power to meet that need as well


    Sent from my iPhone using Tapatalk

  3. The Following User Says Thank You to frm1484 For This Useful Post:

    TerryA (4 Weeks Ago)

Similar Threads

  1. The 500E went in to have a Stone Chip Fixed
    By jaymanek in forum Body Shop
    Replies: 68
    Last Post: 12-10-2018, 02:06 PM
  2. Rough running E420 fixed...THANK YOU!
    By 944s2c in forum M119 Engine
    Replies: 1
    Last Post: 06-10-2015, 07:43 AM
  3. Perfect solution for this heat.
    By Jelmer in forum Off-Topic Discussions
    Replies: 0
    Last Post: 07-23-2013, 11:13 AM
  4. SRS light on, fixed.
    By Gabs in forum Electrical, CAN and Wiring
    Replies: 3
    Last Post: 05-17-2011, 11:46 AM
  5. Battery drain solution found
    By chappardababbar in forum Technology Topics
    Replies: 2
    Last Post: 08-30-2009, 10:04 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •